summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-09-15 04:37:30 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-09-15 04:37:30 +0000
commita17bd9e4bbfce3ad5ee4cc62ad5ceb34d58bf9e2 (patch)
treea98644d2e00a8322248bbde90a37ce665880255d /sci-libs
parentUpdated with required patches to stop build failures with packages that (diff)
downloadgentoo-2-a17bd9e4bbfce3ad5ee4cc62ad5ceb34d58bf9e2.tar.gz
gentoo-2-a17bd9e4bbfce3ad5ee4cc62ad5ceb34d58bf9e2.tar.bz2
gentoo-2-a17bd9e4bbfce3ad5ee4cc62ad5ceb34d58bf9e2.zip
Fix libtool dependency (closing bug #284847, thanks to Kacper Kowalik <xarthisius.kk@gmail.com>). Remove old version which does not compile with hdf5-1.8 (closing bug #267628).
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog9
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch10
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch21
-rw-r--r--sci-libs/mathgl/mathgl-1.8.1.ebuild102
-rw-r--r--sci-libs/mathgl/mathgl-1.9.0.1.ebuild3
5 files changed, 10 insertions, 135 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index d5fb93aec24f..8654570b8575 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.7 2009/08/31 16:18:51 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.8 2009/09/15 04:37:30 grozin Exp $
+
+ 15 Sep 2009; Andrey Grozin <grozin@gentoo.org> -mathgl-1.8.1.ebuild,
+ -files/mathgl-1.8.1-gcc43.patch, -files/mathgl-1.8.1-gcc44.patch,
+ mathgl-1.9.0.1.ebuild:
+ Fix libtool dependency (closing bug #284847, thanks to Kacper Kowalik
+ <xarthisius.kk@gmail.com>). Remove old version which does not compile with
+ hdf5-1.8 (closing bug #267628).
*mathgl-1.9.0.1 (31 Aug 2009)
diff --git a/sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch b/sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch
deleted file mode 100644
index 7a639bb9a4ab..000000000000
--- a/sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- utils/mgl2gif.cpp.ORIG 2009-03-04 14:22:12.000000000 +0100
-+++ utils/mgl2gif.cpp 2009-04-22 10:15:02.000000000 +0200
-@@ -19,6 +19,7 @@
- ***************************************************************************/
- #include <stdio.h>
- #include <string.h>
-+#include <cstdlib>
- #include <locale.h>
- #include <wchar.h>
- #include "mgl/mgl_zb.h"
diff --git a/sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch b/sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch
deleted file mode 100644
index 58eac42ce025..000000000000
--- a/sci-libs/mathgl/files/mathgl-1.8.1-gcc44.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur mathgl-1.8.1.orig/mgl/mgl_addon.cpp mathgl-1.8.1/mgl/mgl_addon.cpp
---- mathgl-1.8.1.orig/mgl/mgl_addon.cpp 2009-03-04 15:22:03.000000000 +0200
-+++ mathgl-1.8.1/mgl/mgl_addon.cpp 2009-08-09 16:33:40.000000000 +0300
-@@ -28,7 +28,7 @@
- //---------------------------------------------------------------------------
- int mgl_strpos(const char *str,char *fnd)
- {
-- char *p=strstr(str,fnd);
-+ const char *p=strstr(str,fnd);
- int res;
- if(p) res = p-str;
- else res = -1;
-@@ -37,7 +37,7 @@
- //---------------------------------------------------------------------------
- int mgl_strpos(const char *str,char ch)
- {
-- char *p=strchr(str,ch);
-+ const char *p=strchr(str,ch);
- int res;
- if(p) res = p-str;
- else res = -1;
diff --git a/sci-libs/mathgl/mathgl-1.8.1.ebuild b/sci-libs/mathgl/mathgl-1.8.1.ebuild
deleted file mode 100644
index 32f9996c49f1..000000000000
--- a/sci-libs/mathgl/mathgl-1.8.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8.1.ebuild,v 1.3 2009/08/09 13:35:22 ssuominen Exp $
-
-EAPI=2
-WX_GTK_VER=2.8
-inherit autotools wxwidgets python versionator toolchain-funcs
-
-DESCRIPTION="Math Graphics Library"
-HOMEPAGE="http://mathgl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwindows"
-
-RDEPEND="media-libs/libpng
- virtual/glu
- python? ( dev-python/numpy )
- glut? ( virtual/glut )
- fltk? ( x11-libs/fltk:1.1 )
- gif? ( media-libs/giflib )
- jpeg? ( media-libs/jpeg )
- hdf5? ( sci-libs/hdf5 )
- gsl? ( sci-libs/gsl )
- octave? ( sci-mathematics/octave )
- qt4? ( x11-libs/qt-gui:4 )
- wxwindows? ( x11-libs/wxGTK:2.8 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/texi2html virtual/texi2dvi )
- python? ( dev-lang/swig )
- octave? ( dev-lang/swig )"
-
-pkg_setup() {
- if ! version_is_at_least "4.3.0" "$(gcc-version)"; then
- eerror "You need >=gcc-4.3.0 to compile this package"
- die "Wrong gcc version"
- fi
-}
-
-src_prepare() {
- # bug #267061
- epatch "${FILESDIR}"/${P}-gcc43.patch
- # bug 274282
- epatch "${FILESDIR}"/${P}-gcc44.patch
-
- # correct location of numpy/arrayobject.h
- if use python; then
- local numpy_h
- numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
- einfo "fixing numpy.i"
- sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
- -i lang/numpy.i \
- || die "sed failed"
- fi
-
- eautoreconf
-}
-
-src_configure() {
- econf --docdir="${ROOT}"usr/share/doc/${PF} \
- $(use_enable glut) \
- $(use_enable qt4 qt) \
- $(use_enable wxwindows wx) \
- $(use_enable fltk) \
- $(use_enable gif) \
- $(use_enable jpeg) \
- $(use_enable hdf5) \
- $(use_enable python) \
- $(use_enable octave) \
- $(use_enable gsl) \
- $(use_enable doc docs)
-}
-
-src_compile() {
- # see bug #249627
- local JOBS
- use doc && JOBS=-j1
- emake ${JOBS} || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README AUTHORS || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use octave; then
- octave <<-EOF
- pkg install /usr/share/${PN}/octave/${PN}.tar.gz
- EOF
- fi
-}
-
-pkg_prerm() {
- if use octave; then
- octave <<-EOF
- pkg uninstall ${PN}
- EOF
- fi
-}
diff --git a/sci-libs/mathgl/mathgl-1.9.0.1.ebuild b/sci-libs/mathgl/mathgl-1.9.0.1.ebuild
index 49f9b94d91ee..545de02ce54f 100644
--- a/sci-libs/mathgl/mathgl-1.9.0.1.ebuild
+++ b/sci-libs/mathgl/mathgl-1.9.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.9.0.1.ebuild,v 1.1 2009/08/31 16:18:51 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.9.0.1.ebuild,v 1.2 2009/09/15 04:37:30 grozin Exp $
EAPI=2
WX_GTK_VER=2.8
@@ -28,6 +28,7 @@ RDEPEND="media-libs/libpng
qt4? ( x11-libs/qt-gui:4 )
wxwindows? ( x11-libs/wxGTK:2.8 )"
DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.4
doc? ( app-text/texi2html virtual/texi2dvi )
python? ( dev-lang/swig )
octave? ( dev-lang/swig )"