summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-28 19:56:18 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-28 19:56:18 +0000
commitb7e2cd8b2f8ba4f6f3a11cabb14302d68aaa0215 (patch)
tree25e569b9640882bf05c02eb76231a718e4bc32fa /sci-libs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-b7e2cd8b2f8ba4f6f3a11cabb14302d68aaa0215.tar.gz
gentoo-2-b7e2cd8b2f8ba4f6f3a11cabb14302d68aaa0215.tar.bz2
gentoo-2-b7e2cd8b2f8ba4f6f3a11cabb14302d68aaa0215.zip
Version Bump, #317261
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cbflib/ChangeLog8
-rw-r--r--sci-libs/cbflib/cbflib-0.9.0.ebuild67
-rw-r--r--sci-libs/cbflib/files/0.9.0-Makefile.patch69
3 files changed, 143 insertions, 1 deletions
diff --git a/sci-libs/cbflib/ChangeLog b/sci-libs/cbflib/ChangeLog
index 43f45b9eae3f..aec893190f6c 100644
--- a/sci-libs/cbflib/ChangeLog
+++ b/sci-libs/cbflib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/cbflib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/ChangeLog,v 1.7 2010/03/31 20:25:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/ChangeLog,v 1.8 2010/04/28 19:56:17 jlec Exp $
+
+*cbflib-0.9.0 (28 Apr 2010)
+
+ 28 Apr 2010; Justin Lecher <jlec@gentoo.org> +files/0.9.0-Makefile.patch,
+ +cbflib-0.9.0.ebuild:
+ Version Bump, #317261
*cbflib-0.8.1-r7 (31 Mar 2010)
diff --git a/sci-libs/cbflib/cbflib-0.9.0.ebuild b/sci-libs/cbflib/cbflib-0.9.0.ebuild
new file mode 100644
index 000000000000..1e8fb654878d
--- /dev/null
+++ b/sci-libs/cbflib/cbflib-0.9.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cbflib/cbflib-0.9.0.ebuild,v 1.1 2010/04/28 19:56:17 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P1="CBFlib-${PV}"
+MY_P2="CBFlib_${PV}"
+
+DESCRIPTION="Library providing a simple mechanism for accessing CBF files and imgCIF files."
+HOMEPAGE="http://www.bernstein-plus-sons.com/software/CBF/"
+#BASE_TEST_URI="http://arcib.dowling.edu/software/CBFlib/downloads/version_${PV}/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P1}_14Feb10.tar.gz"
+# test? (
+# ${BASE_TEST_URI}/${MY_P2}_Data_Files_Input.tar.gz
+# ${BASE_TEST_URI}/${MY_P2}_Data_Files_Output.tar.gz
+# )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+#RDEPEND=""
+#DEPEND="test? ( sys-process/time )"
+
+S="${WORKDIR}/${MY_P1}"
+
+src_prepare(){
+ rm -rvf Py*
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ cp Makefile_LINUX_gcc42 Makefile
+
+ append-fflags -fno-range-check
+ append-cflags -D_USE_XOPEN_EXTENDED
+
+ sed \
+ -e "s:^CC.*$:CC = $(tc-getCC):" \
+ -e "s:^C++.*$:C++ = $(tc-getCXX):" \
+ -e "s:C++:CXX:g" \
+ -e "s:^CFLAGS.*$:CFLAGS = ${CFLAGS}:" \
+ -e "s:^F90C.*$:F90C = $(tc-getFC):" \
+ -e "s:^F90FLAGS.*$:F90FLAGS = ${FFLAGS}:" \
+ -e "s:^SOLDFLAGS.*$:SOLDFLAGS = -shared ${LDFLAGS}:g" \
+ -e "s: /bin: ${EPREFIX}/bin:g" \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake -j1 shared || die
+}
+
+# test app is borked in this version
+# produces buffer overflows
+#src_test(){
+# emake -j1 tests || die
+#}
+
+src_install() {
+ insinto /usr/include/${PN}
+ doins include/* || die
+
+ dolib.so solib/* || die
+}
diff --git a/sci-libs/cbflib/files/0.9.0-Makefile.patch b/sci-libs/cbflib/files/0.9.0-Makefile.patch
new file mode 100644
index 000000000000..27ecdff88fc1
--- /dev/null
+++ b/sci-libs/cbflib/files/0.9.0-Makefile.patch
@@ -0,0 +1,69 @@
+diff --git a/Makefile_LINUX_gcc42 b/Makefile_LINUX_gcc42
+index 52c5286..5d922a7 100644
+--- a/Makefile_LINUX_gcc42
++++ b/Makefile_LINUX_gcc42
+@@ -282,7 +282,7 @@ SHAR = /usr/bin/shar
+ #
+ # Program to use to create archives
+ #
+-AR = /usr/bin/ar
++AR = ar
+
+ #
+ # Program to use to add an index to an archive
+@@ -292,13 +292,13 @@ RANLIB = /usr/bin/ranlib
+ #
+ # Program to use to decompress a data file
+ #
+-DECOMPRESS = /usr/bin/bunzip2
++DECOMPRESS = bunzip2
+
+
+ #
+ # Program to use to compress a data file
+ #
+-COMPRESS = /usr/bin/bzip2
++COMPRESS = bzip2
+
+ #
+ # Program to use to generate a signature
+@@ -486,9 +486,9 @@ F90SOURCE = $(SRC)/fcb_atol_wcnt.f90 \
+ $(SRC)/fcb_read_image.f90 \
+ $(SRC)/fcb_read_line.f90 \
+ $(SRC)/fcb_read_xds_i2.f90 \
+- $(SRC)/fcb_skip_whitespace.f90 \
+- $(EXAMPLES)/test_fcb_read_image.f90 \
+- $(EXAMPLES)/test_xds_binary.f90
++ $(SRC)/fcb_skip_whitespace.f90
++# $(EXAMPLES)/test_fcb_read_image.f90 \
++# $(EXAMPLES)/test_xds_binary.f90
+
+
+ #
+@@ -849,7 +849,7 @@ endif
+ $(SOLIB)/libcbf.so: $(SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
+ $(CC) $(CFLAGS) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
+ mv *.o $(SOLIB)
+- $(CC) -o $@ $(SOLIB)/*.o $(SOLDFLAGS) $(EXTRALIBS)
++ $(CC) $(LDFLAGS) -Wl,-soname,libcbf.so.$(VERSION) $(SOCFLAGS) $(SOLDFLAGS) -o $@ $(SOLIB)/*.o $(EXTRALIBS)
+
+ #
+ # IMG library
+@@ -864,7 +864,7 @@ endif
+
+ $(SOLIB)/libimg.so: $(SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
+ $(CC) $(CFLAGS) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(EXAMPLES)/img.c
+- $(CC) -o $@ img.o $(SOLDFLAGS)
++ $(CC) $(LDFLAGS) -Wl,-soname,libimg.so.$(VERSION) $(SOCFLAGS) $(SOLDFLAGS) -o $@ img.o
+ rm img.o
+
+ #
+@@ -891,7 +891,7 @@ endif
+ $(SOLIB)/libfcb.so: $(F90SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
+ ifneq ($(F90C),)
+ $(F90C) $(F90FLAGS) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(F90SOURCE)
+- $(F90C) $(F90FLAGS) -o $@ *.o $(SOLDFLAGS)
++ $(F90C) $(LDFLAGS) -Wl,-soname,libfcb.so.$(VERSION) $(SOCFLAGS) $(SOLDFLAGS) $(F90FLAGS) -o $@ *.o
+ rm *.o
+ else
+ echo "Define F90C to build $(SOLIB)/libfcb.so"