summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-06-22 11:35:44 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-06-22 11:35:44 +0000
commitc61dcaebdf6da7e8020be61bee4101addfb38ffc (patch)
tree1f59ade359030e0c616c0e2d675835fa582af74a /sci-libs
parentamd64 stable, bug #228593 (diff)
downloadgentoo-2-c61dcaebdf6da7e8020be61bee4101addfb38ffc.tar.gz
gentoo-2-c61dcaebdf6da7e8020be61bee4101addfb38ffc.tar.bz2
gentoo-2-c61dcaebdf6da7e8020be61bee4101addfb38ffc.zip
Added patch to allow compilation with gcc-4.3 (fixes bug #228341).
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-SENTINEL-3 i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog7
-rw-r--r--sci-libs/hdf5/files/hdf5-1.6.6-gcc4.3.patch11
-rw-r--r--sci-libs/hdf5/hdf5-1.6.6.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index b91277c542ab..9ee227967c69 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/hdf5
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.28 2008/06/13 13:22:24 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.29 2008/06/22 11:35:43 markusle Exp $
+
+ 22 Jun 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/hdf5-1.6.6-gcc4.3.patch, hdf5-1.6.6.ebuild:
+ Added patch to allow compilation with gcc-4.3 (fixes bug #228341).
+ Thanks much to Pinky <master_up@post.cz> for his patch.
13 Jun 2008; Markus Dittrich <markusle@gentoo.org> hdf5-1.6.6.ebuild:
Removed sparc specific mask of mpi in DEPEND in favor of package.use.mask
diff --git a/sci-libs/hdf5/files/hdf5-1.6.6-gcc4.3.patch b/sci-libs/hdf5/files/hdf5-1.6.6-gcc4.3.patch
new file mode 100644
index 000000000000..f7a55898eedc
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.6.6-gcc4.3.patch
@@ -0,0 +1,11 @@
+diff -Naur hdf5-1.6.6/c++/src/H5PropList.cpp hdf5-1.6.6.new/c++/src/H5PropList.cpp
+--- hdf5-1.6.6/c++/src/H5PropList.cpp 2007-08-16 12:12:26.000000000 -0400
++++ hdf5-1.6.6.new/c++/src/H5PropList.cpp 2008-06-22 06:32:28.000000000 -0400
+@@ -18,6 +18,7 @@
+ #else
+ #include <iostream>
+ #endif
++#include <stdlib.h>
+ #include <string>
+
+ #include "H5Include.h"
diff --git a/sci-libs/hdf5/hdf5-1.6.6.ebuild b/sci-libs/hdf5/hdf5-1.6.6.ebuild
index c40173ef3264..cf86e3725640 100644
--- a/sci-libs/hdf5/hdf5-1.6.6.ebuild
+++ b/sci-libs/hdf5/hdf5-1.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.6.ebuild,v 1.10 2008/06/13 13:22:24 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.6.ebuild,v 1.11 2008/06/22 11:35:43 markusle Exp $
inherit eutils fixheadtails flag-o-matic fortran toolchain-funcs
@@ -65,6 +65,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
if use mpi; then
# this is required for mpich2, and should be safe otherwise
epatch "${FILESDIR}/${PN}-mpich2.patch"