summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-09 08:49:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-09 08:49:44 +0000
commitd82ea36cc08f586844991077913b9ee1e7f1df3f (patch)
tree35e86f817d8fa51c708e74683e98f9f4f851b730 /sci-libs
parentVersion bump mercurial to 1.9.1. (diff)
downloadgentoo-2-d82ea36cc08f586844991077913b9ee1e7f1df3f.tar.gz
gentoo-2-d82ea36cc08f586844991077913b9ee1e7f1df3f.tar.bz2
gentoo-2-d82ea36cc08f586844991077913b9ee1e7f1df3f.zip
Missing -lz since for example, gzopen is used. Missing zlib.h include wrt #378255 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog7
-rw-r--r--sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch21
-rw-r--r--sci-libs/mathgl/mathgl-1.11.2.ebuild8
3 files changed, 33 insertions, 3 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index 54323ccefc95..d01d7712b2b8 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.24 2011/06/04 18:05:45 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.25 2011/08/09 08:49:44 ssuominen Exp $
+
+ 09 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> mathgl-1.11.2.ebuild,
+ +files/mathgl-1.11.2-zlib.patch:
+ Missing -lz since for example, gzopen is used. Missing zlib.h include wrt
+ #378255 by Diego Elio Pettenò
*mathgl-1.11.2 (04 Jun 2011)
diff --git a/sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch b/sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch
new file mode 100644
index 000000000000..401f5b0d9fcf
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch
@@ -0,0 +1,21 @@
+--- mgl/Makefile.am
++++ mgl/Makefile.am
+@@ -16,7 +16,7 @@
+ WIDGETS += -DWITH_GLUT
+ endif
+
+-libmgl_la_LIBADD = $(PNG_LIBS) $(GL_LIBS) $(LOPENMP)
++libmgl_la_LIBADD = $(PNG_LIBS) -lz $(GL_LIBS) $(LOPENMP)
+ libmgl_la_LDFLAGS = -no-undefined -version-info $(MGL_CURRENT):$(MGL_REVISION):$(MGL_AGE)
+
+ libmgl_la_CXXFLAGS = $(WIDGETS) -DMGL_FONT_PATH=\"$(datadir)/$(PACKAGE)/fonts/\" \
+--- mgl/mgl_data_png.cpp
++++ mgl/mgl_data_png.cpp
+@@ -18,6 +18,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+ #include <stdlib.h>
++#include <zlib.h>
+ #ifndef NO_PNG
+ #include <png.h>
+ #endif
diff --git a/sci-libs/mathgl/mathgl-1.11.2.ebuild b/sci-libs/mathgl/mathgl-1.11.2.ebuild
index 850ddb281907..a6208f615719 100644
--- a/sci-libs/mathgl/mathgl-1.11.2.ebuild
+++ b/sci-libs/mathgl/mathgl-1.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.11.2.ebuild,v 1.1 2011/06/04 18:05:45 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.11.2.ebuild,v 1.2 2011/08/09 08:49:44 ssuominen Exp $
EAPI=3
@@ -9,7 +9,7 @@ PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit autotools wxwidgets python versionator toolchain-funcs
+inherit autotools eutils wxwidgets python versionator toolchain-funcs
DESCRIPTION="Math Graphics Library"
HOMEPAGE="http://mathgl.sourceforge.net/"
@@ -21,6 +21,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwidgets"
RDEPEND="media-libs/libpng
+ sys-libs/zlib
virtual/opengl
python? ( dev-python/numpy )
glut? ( media-libs/freeglut )
@@ -65,6 +66,9 @@ src_prepare() {
# bug #358245
epatch "${FILESDIR}"/${PN}-octave-3.4.patch
+ # bug #378255
+ epatch "${FILESDIR}"/${PN}-1.11.2-zlib.patch
+
# correct location of numpy/arrayobject.h
if use python; then
sed \