summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-26 11:50:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-26 11:50:14 +0000
commitdf5e451b9f5ea50e39facd1a85ab7d5f59be26a2 (patch)
treed052174ea2b639db6c1566a01434c8ae3abbff68 /sci-libs
parentRevision bump to make 1.4.3-r1 the new stable candidate with support for ruby... (diff)
downloadgentoo-2-df5e451b9f5ea50e39facd1a85ab7d5f59be26a2.tar.gz
gentoo-2-df5e451b9f5ea50e39facd1a85ab7d5f59be26a2.tar.bz2
gentoo-2-df5e451b9f5ea50e39facd1a85ab7d5f59be26a2.zip
Fix for Python ABIs, #316221; corrected HOMEPAGE
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog8
-rw-r--r--sci-libs/geos/files/3.2.0-multipy.patch13
-rw-r--r--sci-libs/geos/geos-3.1.1.ebuild4
-rw-r--r--sci-libs/geos/geos-3.2.0-r1.ebuild77
-rw-r--r--sci-libs/geos/geos-3.2.0.ebuild4
5 files changed, 101 insertions, 5 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 685adf6b8099..e22acb819e6a 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.42 2010/01/12 20:09:21 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.43 2010/06/26 11:50:13 jlec Exp $
+
+*geos-3.2.0-r1 (26 Jun 2010)
+
+ 26 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/3.2.0-multipy.patch,
+ geos-3.1.1.ebuild, geos-3.2.0.ebuild, +geos-3.2.0-r1.ebuild:
+ Fix for Python ABIs, #316221; corrected HOMEPAGE
12 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> geos-3.2.0.ebuild:
Fixed for strict amd64
diff --git a/sci-libs/geos/files/3.2.0-multipy.patch b/sci-libs/geos/files/3.2.0-multipy.patch
new file mode 100644
index 000000000000..652b0f64d871
--- /dev/null
+++ b/sci-libs/geos/files/3.2.0-multipy.patch
@@ -0,0 +1,13 @@
+diff --git a/swig/Makefile.am b/swig/Makefile.am
+index 765744d..ed40831 100644
+--- a/swig/Makefile.am
++++ b/swig/Makefile.am
+@@ -6,7 +6,7 @@ if ENABLE_RUBY
+ MAYBERUBY = ruby
+ endif
+
+-SUBDIRS = $(MAYBEPYTHON) $(MAYBERUBY)
++SUBDIRS = $(MAYBERUBY)
+
+ EXTRA_DIST = \
+ geos.i
diff --git a/sci-libs/geos/geos-3.1.1.ebuild b/sci-libs/geos/geos-3.1.1.ebuild
index 841892fa98b2..f514f9916b57 100644
--- a/sci-libs/geos/geos-3.1.1.ebuild
+++ b/sci-libs/geos/geos-3.1.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.1.1.ebuild,v 1.8 2010/01/07 02:50:56 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.1.1.ebuild,v 1.9 2010/06/26 11:50:13 jlec Exp $
EAPI=2
inherit eutils
DESCRIPTION="Geometry engine library for Geographic Information Systems"
-HOMEPAGE="http://geos.refractions.net"
+HOMEPAGE="http://trac.osgeo.org/geos/"
SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
LICENSE="LGPL-2.1"
diff --git a/sci-libs/geos/geos-3.2.0-r1.ebuild b/sci-libs/geos/geos-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..407c60901acb
--- /dev/null
+++ b/sci-libs/geos/geos-3.2.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.1 2010/06/26 11:50:13 jlec Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools eutils python
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-multipy.patch
+ eautoreconf
+ echo "#!/${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf $(use_enable python) $(use_enable ruby)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use python; then
+ python_copy_sources swig/python
+ building() {
+ emake \
+ PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ PYTHON_LDFLAGS="$(python_get_library -l)" \
+ SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir swig/python building
+ fi
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use python; then
+ python_copy_sources swig/python
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pythondir="$(python_get_sitedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir swig/python installation
+ python_clean_installation_image
+ fi
+ dodoc AUTHORS NEWS README TODO || die
+ if use doc; then
+ cd "${S}/doc"
+ dohtml -r doxygen_docs/html/* || die
+ fi
+}
diff --git a/sci-libs/geos/geos-3.2.0.ebuild b/sci-libs/geos/geos-3.2.0.ebuild
index 833545c41f68..29d0fa5d984a 100644
--- a/sci-libs/geos/geos-3.2.0.ebuild
+++ b/sci-libs/geos/geos-3.2.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0.ebuild,v 1.2 2010/01/12 20:09:21 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0.ebuild,v 1.3 2010/06/26 11:50:14 jlec Exp $
EAPI=2
DESCRIPTION="Geometry engine library for Geographic Information Systems"
-HOMEPAGE="http://geos.refractions.net"
+HOMEPAGE="http://trac.osgeo.org/geos/"
SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
LICENSE="LGPL-2.1"