summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-12 08:01:34 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-12 08:01:34 +0000
commite40e5175fe8ba0d5e57a298fa100ff5bbf53b3cf (patch)
tree1fffa021a6f7f6a4d7510669ff7ac1cc9363917d /sci-libs
parentsci-chemistry/ccpn: Todays Python Patches (diff)
downloadgentoo-2-e40e5175fe8ba0d5e57a298fa100ff5bbf53b3cf.tar.gz
gentoo-2-e40e5175fe8ba0d5e57a298fa100ff5bbf53b3cf.tar.bz2
gentoo-2-e40e5175fe8ba0d5e57a298fa100ff5bbf53b3cf.zip
sci-libs/ccpn-data: Todays Python Patches
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ccpn-data/ChangeLog7
-rw-r--r--sci-libs/ccpn-data/ccpn-data-2.2.2_p121112.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-libs/ccpn-data/ChangeLog b/sci-libs/ccpn-data/ChangeLog
index cc982361752a..0e17774b2a3e 100644
--- a/sci-libs/ccpn-data/ChangeLog
+++ b/sci-libs/ccpn-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/ccpn-data
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.11 2012/10/12 16:25:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.12 2012/11/12 08:01:34 jlec Exp $
+
+*ccpn-data-2.2.2_p121112 (12 Nov 2012)
+
+ 12 Nov 2012; Justin Lecher <jlec@gentoo.org> +ccpn-data-2.2.2_p121112.ebuild:
+ Todays Python Patches
*ccpn-data-2.2.2_p121012 (12 Oct 2012)
diff --git a/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112.ebuild b/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112.ebuild
new file mode 100644
index 000000000000..e5cc98c40647
--- /dev/null
+++ b/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112.ebuild,v 1.1 2012/11/12 08:01:34 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit portability python versionator
+
+PATCHSET="${PV##*_p}"
+MY_PN="${PN/-data}mr"
+MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
+MY_MAJOR="$(get_version_component_range 1-3)"
+
+DESCRIPTION="The Collaborative Computing Project for NMR - Data"
+HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
+SRC_URI="http://www2.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
+[[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
+
+SLOT="0"
+LICENSE="|| ( CCPN LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!<sci-chemistry/ccpn-${PVR}"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"/ccpnmr/ccpnmr2.2
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ [[ -n ${PATCHSET} ]] && \
+ epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
+}
+
+src_install() {
+ local i pydocs in_path
+
+ dodir /usr/share/doc/${PF}/html
+ sed \
+ -e "s:../ccpnmr2.1:${EPREFIX}/usr/share/doc/${PF}/html:g" \
+ ../doc/index.html > "${ED}"/usr/share/doc/${PF}/html/index.html || die
+ treecopy $(find python/ -name doc -type d) "${ED}"/usr/share/doc/${PF}/html/
+
+ pydocs="$(find python -name doc -type d)"
+ in_path=$(python_get_sitedir)/ccpn
+
+ dosym ../../../../share/doc/${PF}/html ${in_path}/doc
+ for i in ${pydocs}; do
+ dosym /usr/share/doc/${PF}/html/${i} ${in_path}/${i}
+ done
+
+ dosym /usr/share/ccpn/data ${in_path}/data
+ dosym /usr/share/ccpn/model ${in_path}/model
+
+ dohtml -r doc/*
+ insinto /usr/share/ccpn
+ doins -r data model
+}