summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-10 10:33:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-10 10:33:04 +0000
commit791092ae802a0096691921c77f987bbf919c2a84 (patch)
treec16ae157257aaf2525673b4c775af10a2775de55 /sci-mathematics/freemat
parentconvert SRC_URI to comply with gentoo-xfce standards or whatever (diff)
downloadgentoo-2-791092ae802a0096691921c77f987bbf919c2a84.tar.gz
gentoo-2-791092ae802a0096691921c77f987bbf919c2a84.tar.bz2
gentoo-2-791092ae802a0096691921c77f987bbf919c2a84.zip
Pull in GLU headers for "gluProject" wrt #402361 by Helmut Jarausch. This is required for compability with x11-libs/qt-opengl >= 4.8.0.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/freemat')
-rw-r--r--sci-mathematics/freemat/ChangeLog9
-rw-r--r--sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch14
-rw-r--r--sci-mathematics/freemat/freemat-4.0.ebuild8
3 files changed, 26 insertions, 5 deletions
diff --git a/sci-mathematics/freemat/ChangeLog b/sci-mathematics/freemat/ChangeLog
index 6625d5617017..3e757fedfe28 100644
--- a/sci-mathematics/freemat/ChangeLog
+++ b/sci-mathematics/freemat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/freemat
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/ChangeLog,v 1.23 2011/11/25 21:03:56 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/ChangeLog,v 1.24 2012/03/10 10:33:04 ssuominen Exp $
+
+ 10 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> freemat-4.0.ebuild,
+ +files/freemat-4.0-no_implicit_GLU.patch:
+ Pull in GLU headers for "gluProject" wrt #402361 by Helmut Jarausch. This is
+ required for compability with x11-libs/qt-opengl >= 4.8.0.
25 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> -freemat-3.6.ebuild,
-files/freemat-3.6-gcc44.patch, -files/freemat-3.6-includes.patch,
diff --git a/sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch b/sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch
new file mode 100644
index 000000000000..dd3798bb8f6a
--- /dev/null
+++ b/sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch
@@ -0,0 +1,14 @@
+error: 'gluProject' was not declared in this scope
+
+http://bugs.gentoo.org/402361
+
+--- libs/libGraphics/GLRenderEngine.cpp
++++ libs/libGraphics/GLRenderEngine.cpp
+@@ -20,6 +20,7 @@
+ #include <qimage.h>
+ #include <qpainter.h>
+ #include <QtOpenGL>
++#include <GL/glu.h>
+ #include <math.h>
+ #include "IEEEFP.hpp"
+
diff --git a/sci-mathematics/freemat/freemat-4.0.ebuild b/sci-mathematics/freemat/freemat-4.0.ebuild
index 4d8a781dea82..429c5b13ed44 100644
--- a/sci-mathematics/freemat/freemat-4.0.ebuild
+++ b/sci-mathematics/freemat/freemat-4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-4.0.ebuild,v 1.3 2010/05/05 16:11:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-4.0.ebuild,v 1.4 2012/03/10 10:33:04 ssuominen Exp $
EAPI="2"
inherit eutils cmake-utils fdo-mime
@@ -36,7 +36,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}.1-Source"
src_prepare(){
- epatch "${FILESDIR}"/${P}-gcc45.patch
+ epatch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-no_implicit_GLU.patch
}
src_configure() {