summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-30 09:23:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-30 09:23:26 +0000
commita6d572a9ad16204c26d9ab8ce8f8566a3c12124d (patch)
tree5f49348e3af1fafad2575484b89d0170a407a60e /sci-mathematics/msieve
parent0.9.8 version bump. (diff)
downloadgentoo-2-a6d572a9ad16204c26d9ab8ce8f8566a3c12124d.tar.gz
gentoo-2-a6d572a9ad16204c26d9ab8ce8f8566a3c12124d.tar.bz2
gentoo-2-a6d572a9ad16204c26d9ab8ce8f8566a3c12124d.zip
Reducing output verbosity some more
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/msieve')
-rw-r--r--sci-mathematics/msieve/ChangeLog6
-rw-r--r--sci-mathematics/msieve/files/reduce-printf2.patch58
-rw-r--r--sci-mathematics/msieve/files/reduce-printf3.patch31
-rw-r--r--sci-mathematics/msieve/msieve-1.50-r4.ebuild4
4 files changed, 97 insertions, 2 deletions
diff --git a/sci-mathematics/msieve/ChangeLog b/sci-mathematics/msieve/ChangeLog
index 488971f05727..e9475cab6873 100644
--- a/sci-mathematics/msieve/ChangeLog
+++ b/sci-mathematics/msieve/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/msieve
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/ChangeLog,v 1.8 2012/11/30 08:52:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/ChangeLog,v 1.9 2012/11/30 09:23:26 patrick Exp $
+
+ 30 Nov 2012; Patrick Lauer <patrick@gentoo.org> +files/reduce-printf2.patch,
+ +files/reduce-printf3.patch, msieve-1.50-r4.ebuild:
+ Reducing output verbosity some more
*msieve-1.50-r4 (30 Nov 2012)
diff --git a/sci-mathematics/msieve/files/reduce-printf2.patch b/sci-mathematics/msieve/files/reduce-printf2.patch
new file mode 100644
index 000000000000..a59e1722758a
--- /dev/null
+++ b/sci-mathematics/msieve/files/reduce-printf2.patch
@@ -0,0 +1,58 @@
+--- gnfs/poly/stage2/root_sieve_deg45_x.c 2011-08-23 20:59:59.000000000 +0800
++++ gnfs/poly/stage2/root_sieve_deg45_x.c.new 2012-11-30 17:09:22.553116526 +0800
+@@ -515,7 +515,7 @@
+ if (obj->flags & MSIEVE_FLAG_STOP_SIEVING)
+ break;
+ }
+- printf("\n");
++ printf(".");
+ return;
+ }
+
+@@ -585,7 +585,7 @@
+ if (obj->flags & MSIEVE_FLAG_STOP_SIEVING)
+ break;
+ }
+- printf("\n");
++ printf(",");
+ }
+
+ /*-------------------------------------------------------------------------*/
+@@ -604,7 +604,7 @@
+ xline_heap_t xline_heap;
+ uint32 cutoff_score;
+
+- printf("L %u\n", (uint32)lattice_size);
++ /* printf("L %u\n", (uint32)lattice_size); */
+
+ mpz_set_ui(xy->y_base, (unsigned long)0);
+ xy->y_blocks = 0;
+@@ -621,7 +621,7 @@
+ x->x_blocks = line_max - line_min;
+ x->curr_score = 0;
+ root_sieve_line(rs);
+- printf("\n");
++ printf("_");
+ return;
+ }
+
+@@ -664,5 +664,5 @@
+ break;
+ }
+
+- printf("\n");
++ printf("*");
+ }
+--- gnfs/poly/stage2/root_sieve_deg5_xy.c 2011-07-15 09:49:00.000000000 +0800
++++ gnfs/poly/stage2/root_sieve_deg5_xy.c.new 2012-11-30 17:09:51.462454813 +0800
+@@ -290,8 +290,8 @@
+ }
+ xy->y_blocks = y_blocks;
+
+- printf("\n%.0lf %u %u\n", (double)lattice_size,
+- y_blocks, num_lattices);
++ /* printf("\n%.0lf %u %u\n", (double)lattice_size,
++ y_blocks, num_lattices); */
+
+ sieve_x_run_deg5(rs);
+ }
diff --git a/sci-mathematics/msieve/files/reduce-printf3.patch b/sci-mathematics/msieve/files/reduce-printf3.patch
new file mode 100644
index 000000000000..dedadde51d42
--- /dev/null
+++ b/sci-mathematics/msieve/files/reduce-printf3.patch
@@ -0,0 +1,31 @@
+--- gnfs/poly/poly_skew.c 2011-12-23 03:48:49.000000000 +0800
++++ gnfs/poly/poly_skew.c.new 2012-11-30 17:14:29.802747785 +0800
+@@ -221,7 +221,7 @@
+ static void stage1_callback(mpz_t high_coeff, mpz_t p, mpz_t m,
+ double coeff_bound, void *extra) {
+
+- gmp_printf("%Zd %Zd %Zd\n", high_coeff, p, m);
++ /* gmp_printf("%Zd %Zd %Zd\n", high_coeff, p, m); */
+ poly_stage2_run((poly_stage2_t *)extra, high_coeff, p, m,
+ coeff_bound, NULL);
+ }
+@@ -231,7 +231,7 @@
+ double coeff_bound, void *extra) {
+
+ FILE *mfile = (FILE *)extra;
+- gmp_printf("%Zd %Zd %Zd\n", high_coeff, p, m);
++ /* gmp_printf("%Zd %Zd %Zd\n", high_coeff, p, m); */
+ gmp_fprintf(mfile, "%Zd %Zd %Zd\n",
+ high_coeff, p, m);
+ fflush(mfile);
+--- gnfs/poly/stage2/root_sieve_line.c 2011-11-25 00:25:28.000000000 +0800
++++ gnfs/poly/stage2/root_sieve_line.c.new 2012-11-30 17:18:19.887475567 +0800
+@@ -402,7 +402,7 @@
+ uint32 num_primes = rs->num_primes;
+ uint16 *block = rs->sieve_block;
+
+- printf("%u ", num_blocks); fflush(stdout);
++ /* printf("%u ", num_blocks); fflush(stdout); */
+
+ if (mpz_cmp_ui(x->mp_lattice_size, 1) == 0)
+ prepare_sieve_line(rs);
diff --git a/sci-mathematics/msieve/msieve-1.50-r4.ebuild b/sci-mathematics/msieve/msieve-1.50-r4.ebuild
index d472871ba1fd..8fce9795eec3 100644
--- a/sci-mathematics/msieve/msieve-1.50-r4.ebuild
+++ b/sci-mathematics/msieve/msieve-1.50-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50-r4.ebuild,v 1.1 2012/11/30 08:52:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50-r4.ebuild,v 1.2 2012/11/30 09:23:26 patrick Exp $
EAPI=4
DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
@@ -22,6 +22,8 @@ RDEPEND="${DEPEND}"
src_prepare() {
# TODO: Integrate ggnfs properly
epatch "${FILESDIR}/reduce-printf.patch" || die
+ epatch "${FILESDIR}/reduce-printf2.patch" || die
+ epatch "${FILESDIR}/reduce-printf3.patch" || die
epatch "${FILESDIR}/fix-version.patch" || die
epatch "${FILESDIR}/fix-version2.patch" || die
sed -i -e 's/-march=k8//' Makefile || die