summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-13 02:22:15 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-13 02:22:15 +0000
commit2876d3790bd235177398d6cef8fc9ca6e3b48c82 (patch)
treead993bad05d9ae132a25f4664082429ba762304e /sci-mathematics/nusmv
parentStable for HPPA (bug #325825). (diff)
downloadgentoo-2-2876d3790bd235177398d6cef8fc9ca6e3b48c82.tar.gz
gentoo-2-2876d3790bd235177398d6cef8fc9ca6e3b48c82.tar.bz2
gentoo-2-2876d3790bd235177398d6cef8fc9ca6e3b48c82.zip
Remove forced -mcpu=pentium4 from cudd's Makefile. This fixes bug #327425 reported by Christopher Head <chris2k01@hotmail.com>. Also, added code to use correct Makefile for 64-bit systems.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/nusmv')
-rw-r--r--sci-mathematics/nusmv/ChangeLog8
-rw-r--r--sci-mathematics/nusmv/files/cudd-no-pentium4.patch11
-rw-r--r--sci-mathematics/nusmv/nusmv-2.5.0.ebuild9
3 files changed, 26 insertions, 2 deletions
diff --git a/sci-mathematics/nusmv/ChangeLog b/sci-mathematics/nusmv/ChangeLog
index 90480a1f68e7..639748f95bd4 100644
--- a/sci-mathematics/nusmv/ChangeLog
+++ b/sci-mathematics/nusmv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/nusmv
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/ChangeLog,v 1.9 2010/06/22 20:03:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/ChangeLog,v 1.10 2010/07/13 02:22:15 phajdan.jr Exp $
+
+ 13 Jul 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/cudd-no-pentium4.patch, nusmv-2.5.0.ebuild:
+ Remove forced -mcpu=pentium4 from cudd's Makefile. This fixes bug #327425
+ reported by Christopher Head <chris2k01@hotmail.com>. Also, added code to
+ use correct Makefile for 64-bit systems.
*nusmv-2.5.0 (22 Jun 2010)
diff --git a/sci-mathematics/nusmv/files/cudd-no-pentium4.patch b/sci-mathematics/nusmv/files/cudd-no-pentium4.patch
new file mode 100644
index 000000000000..844f7c00d638
--- /dev/null
+++ b/sci-mathematics/nusmv/files/cudd-no-pentium4.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2010-07-12 02:54:26.000000000 +0200
++++ Makefile 2010-07-12 02:54:49.000000000 +0200
+@@ -69,7 +69,7 @@
+ # Gcc 2.8.1 or higher on i686.
+ #XCFLAGS = -mcpu=pentiumpro -malign-double -DHAVE_IEEE_754 -DBSD
+ # Gcc 3.2.2 or higher on i686.
+-XCFLAGS = -mcpu=pentium4 -malign-double -DHAVE_IEEE_754 -DBSD -DSIZEOF_VOID_P=4 -DSIZEOF_LONG=4 -DSIZEOF_INT=4
++XCFLAGS = -malign-double -DHAVE_IEEE_754 -DBSD -DSIZEOF_VOID_P=4 -DSIZEOF_LONG=4 -DSIZEOF_INT=4
+ # Icc on i686.
+ #XCFLAGS = -ansi -align -ip -DHAVE_IEEE_754 -DBSD
+ # Gcc on ia64.
diff --git a/sci-mathematics/nusmv/nusmv-2.5.0.ebuild b/sci-mathematics/nusmv/nusmv-2.5.0.ebuild
index 15461364a9de..dd461fc55f7d 100644
--- a/sci-mathematics/nusmv/nusmv-2.5.0.ebuild
+++ b/sci-mathematics/nusmv/nusmv-2.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/nusmv-2.5.0.ebuild,v 1.1 2010/06/22 20:03:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/nusmv-2.5.0.ebuild,v 1.2 2010/07/13 02:22:15 phajdan.jr Exp $
inherit eutils toolchain-funcs
@@ -57,6 +57,13 @@ src_unpack() {
epatch "${FILESDIR}"/${MINISAT_P}-optimizedlib.patch
epatch "${FILESDIR}"/${MINISAT_P}_gcc41.patch
fi
+
+ cd "${CUDD_S}"
+ epatch "${FILESDIR}"/${CUDD_PN}-no-pentium4.patch
+ if [[ "$(tc-arch)" = amd64 ]] ; then
+ mv Makefile_64bit Makefile || die
+ fi
+
for i in ${NUSMV_S}/doc/{user-man,tutorial}/Makefile.in ; do
sed -i.orig \
'/install_sh_DATA/s!$(datadir)!$(DESTDIR)$(datadir)!g' \