summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-06-04 21:52:41 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-06-04 21:52:41 +0000
commit8c2ade216b0a658186b7f26174b787aee959718b (patch)
treed883ac5870cec20574e263b3e89ee4e779bc835b /sci-mathematics/octave
parentFixed broken Manifest. (diff)
downloadgentoo-2-8c2ade216b0a658186b7f26174b787aee959718b.tar.gz
gentoo-2-8c2ade216b0a658186b7f26174b787aee959718b.tar.bz2
gentoo-2-8c2ade216b0a658186b7f26174b787aee959718b.zip
Added warning about agressive CFLAGS. (See bug #76067.)
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/Manifest6
-rw-r--r--sci-mathematics/octave/octave-2.1.57-r1.ebuild20
-rw-r--r--sci-mathematics/octave/octave-2.1.64.ebuild20
-rw-r--r--sci-mathematics/octave/octave-2.1.69.ebuild20
5 files changed, 65 insertions, 7 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 427214f3ea66..7b0a06e7bb4d 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.6 2005/06/04 19:54:52 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.7 2005/06/04 21:52:41 ribosome Exp $
+
+ 04 Jun 2005; Olivier Fisette <ribosome@gentoo.org>
+ octave-2.1.57-r1.ebuild, octave-2.1.64.ebuild, octave-2.1.69.ebuild:
+ Added warning about agressive CFLAGS. (See bug #76067.)
04 Jun 2005; Olivier Fisette <ribosome@gentoo.org>
-octave-2.1.36-r1.ebuild, -octave-2.1.50.ebuild, -octave-2.1.57.ebuild:
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
index d59b16cd4e22..47514737fcea 100644
--- a/sci-mathematics/octave/Manifest
+++ b/sci-mathematics/octave/Manifest
@@ -1,6 +1,6 @@
-MD5 1640f68fc62f00f0ba14bbcbde828641 octave-2.1.69.ebuild 2541
-MD5 855cac1740d656f2e90c758ef5b512ff octave-2.1.64.ebuild 2892
-MD5 3f3dfb31707c80aa98b1dff257aadb58 octave-2.1.57-r1.ebuild 2862
+MD5 142349e1bd60722d1fe5ea852d4d6d15 octave-2.1.69.ebuild 3264
+MD5 fa718104741d2b643f5e7b1638db99c2 octave-2.1.64.ebuild 3615
+MD5 a26bf0f708455c105681935bdb3665e4 octave-2.1.57-r1.ebuild 3585
MD5 fa62e07a6e601d6d5b13ae211c36491f ChangeLog 7520
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 32c6cee1f5b42b8b20369c3722fb4db2 files/digest-octave-2.1.57-r1 67
diff --git a/sci-mathematics/octave/octave-2.1.57-r1.ebuild b/sci-mathematics/octave/octave-2.1.57-r1.ebuild
index e749d09cad20..5173b50d1060 100644
--- a/sci-mathematics/octave/octave-2.1.57-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.57-r1.ebuild,v 1.5 2005/04/18 16:19:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.57-r1.ebuild,v 1.6 2005/06/04 21:52:41 ribosome Exp $
inherit flag-o-matic
@@ -90,6 +90,24 @@ src_install() {
fi
}
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
octave-install-doc() {
echo "Installing documentation..."
insinto /usr/share/doc/${PF}
diff --git a/sci-mathematics/octave/octave-2.1.64.ebuild b/sci-mathematics/octave/octave-2.1.64.ebuild
index 80ee779d589d..5cae9d649a03 100644
--- a/sci-mathematics/octave/octave-2.1.64.ebuild
+++ b/sci-mathematics/octave/octave-2.1.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.64.ebuild,v 1.5 2005/06/04 19:54:52 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.64.ebuild,v 1.6 2005/06/04 21:52:41 ribosome Exp $
inherit flag-o-matic
@@ -91,6 +91,24 @@ src_install() {
fi
}
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
octave-install-doc() {
echo "Installing documentation..."
insinto /usr/share/doc/${PF}
diff --git a/sci-mathematics/octave/octave-2.1.69.ebuild b/sci-mathematics/octave/octave-2.1.69.ebuild
index f7c5ca632b47..ceb90636ac91 100644
--- a/sci-mathematics/octave/octave-2.1.69.ebuild
+++ b/sci-mathematics/octave/octave-2.1.69.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.1 2005/04/21 21:05:41 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.2 2005/06/04 21:52:41 ribosome Exp $
inherit flag-o-matic
@@ -77,6 +77,24 @@ src_install() {
fi
}
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
octave-install-doc() {
echo "Installing documentation..."
insinto /usr/share/doc/${PF}