summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2005-11-08 17:41:36 +0000
committerGeorge Shapovalov <george@gentoo.org>2005-11-08 17:41:36 +0000
commit49aa4996b1aa345d39255d8984962264cd3beb61 (patch)
tree581fcc12db9e0e072317a39d54640454e3ef3d57 /sci-mathematics/pari/pari-2.1.6.ebuild
parentZe depends, ze depends. Aye, fixing doc depends. Resolves bug #108994 (diff)
downloadgentoo-2-49aa4996b1aa345d39255d8984962264cd3beb61.tar.gz
gentoo-2-49aa4996b1aa345d39255d8984962264cd3beb61.tar.bz2
gentoo-2-49aa4996b1aa345d39255d8984962264cd3beb61.zip
fix for sparc arch (#87790)
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-mathematics/pari/pari-2.1.6.ebuild')
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index a7cd904d7029..505808630c2f 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.13 2005/11/08 14:46:51 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.14 2005/11/08 17:41:36 george Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa mips ppc x86"
+KEYWORDS="alpha amd64 hppa mips ppc ~sparc x86"
IUSE="doc emacs"
DEPEND="doc? ( virtual/tetex )"
@@ -26,6 +26,12 @@ src_compile() {
# Fix usage of toolchain
tc-getAS; tc-getLD; tc-getCC; tc-getCXX
+ # Special handling for sparc
+ local myhost
+ [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
+ || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
+ einfo "Building for ${myhost}"
+
#need to force optimization here, as it breaks without
if is-flag -O0; then
replace-flags -O0 -O2
@@ -36,7 +42,7 @@ src_compile() {
if [ "${ARCH}" = "amd64" ] && ! is-flag -fPIC; then append-flags -fPIC; fi
./Configure \
- --host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
+ --host=${myhost} \
--prefix=/usr \
--miscdir=/usr/share/doc/${PF} \
--datadir=/usr/share/${P} \