summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 13:50:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 13:50:00 +0000
commitebc5f8295f3d295c64096ce823f90a45a377c285 (patch)
treef1f2b15fb11b08ca35f80f58bac98a8ef351ae5e /sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
parentUpdate to latest beta; drop all keywords but the two that haven't updated fro... (diff)
downloadgentoo-2-ebc5f8295f3d295c64096ce823f90a45a377c285.tar.gz
gentoo-2-ebc5f8295f3d295c64096ce823f90a45a377c285.tar.bz2
gentoo-2-ebc5f8295f3d295c64096ce823f90a45a377c285.zip
Added fix for insecure runpaths, #291595, some QA
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild')
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
index 242ba1c244b9..9374501c777d 100644
--- a/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild,v 1.3 2009/12/04 04:37:20 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild,v 1.4 2010/06/24 13:50:00 jlec Exp $
EAPI="2"
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils
+
+inherit cmake-utils multilib
DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
HOMEPAGE="http://forja.rediris.es/projects/csl-qtoctave/"
@@ -24,16 +25,9 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${P}/${PN}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.8.1-gcc4.4.patch
-}
-
-src_compile() {
- mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
- cmake-utils_src_compile
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.1-gcc4.4.patch
+ "${FILESDIR}"/${P}-rpath.patch
+ )
-src_install() {
- cmake-utils_src_install
- dodoc readme.txt news.txt
-}
+DOCS=(readme.txt news.txt)