summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-03-15 15:23:01 +0000
committerMichael Januszewski <spock@gentoo.org>2008-03-15 15:23:01 +0000
commit52c0f42ae1f64183b7b4dfcb86c7bcbba0356dd4 (patch)
tree18d3db85a8a6d7b779bce71b88bebb61a4f13c5a /sci-mathematics/xmds
parentSigning failed, re-sign. (diff)
downloadgentoo-2-52c0f42ae1f64183b7b4dfcb86c7bcbba0356dd4.tar.gz
gentoo-2-52c0f42ae1f64183b7b4dfcb86c7bcbba0356dd4.tar.bz2
gentoo-2-52c0f42ae1f64183b7b4dfcb86c7bcbba0356dd4.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics/xmds')
-rw-r--r--sci-mathematics/xmds/ChangeLog7
-rw-r--r--sci-mathematics/xmds/xmds-1.6.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/sci-mathematics/xmds/ChangeLog b/sci-mathematics/xmds/ChangeLog
index 9a31ac8ab2e5..31aed73883c8 100644
--- a/sci-mathematics/xmds/ChangeLog
+++ b/sci-mathematics/xmds/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/xmds
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/ChangeLog,v 1.1 2008/01/20 17:42:47 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/ChangeLog,v 1.2 2008/03/15 15:23:01 spock Exp $
+
+*xmds-1.6.5 (15 Mar 2008)
+
+ 15 Mar 2008; Michał Januszewski <spock@gentoo.org> +xmds-1.6.5.ebuild:
+ Version bump.
*xmds-1.6.4 (20 Jan 2008)
diff --git a/sci-mathematics/xmds/xmds-1.6.5.ebuild b/sci-mathematics/xmds/xmds-1.6.5.ebuild
new file mode 100644
index 000000000000..f57dadee9333
--- /dev/null
+++ b/sci-mathematics/xmds/xmds-1.6.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/xmds-1.6.5.ebuild,v 1.1 2008/03/15 15:23:01 spock Exp $
+
+doc_ver=20080226
+
+DESCRIPTION="XMDS - The eXtensible Multi-Dimensional Simulator"
+HOMEPAGE="http://www.xmds.org"
+SRC_URI="mirror://sourceforge/xmds/${P}.tar.gz
+ doc? ( mirror://sourceforge/xmds/xmds_doc_${doc_ver}.pdf )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples mpi threads"
+
+DEPEND="sci-libs/fftw
+ mpi? ( virtual/mpi )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_compile() {
+ local my_opts=""
+
+ if has_version "=sci-libs/fftw-3*" ; then
+ my_opts="${my_opts} --enable-fftw3"
+ fi
+
+ econf \
+ $(use_enable mpi) \
+ $(use_enable threads) \
+ ${my_opts} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/xmds_doc${doc_ver}.pdf"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}