summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-12-13 11:31:32 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-12-13 11:31:32 +0000
commit1bc3cc26308dc9a31e04a0d2eb6140aa893bdcb9 (patch)
tree0757f56ff4c255208a4ab52a940d0f045bc606c6 /sci-mathematics/yacas
parentinitial import, bug #105094 (diff)
downloadgentoo-2-1bc3cc26308dc9a31e04a0d2eb6140aa893bdcb9.tar.gz
gentoo-2-1bc3cc26308dc9a31e04a0d2eb6140aa893bdcb9.tar.bz2
gentoo-2-1bc3cc26308dc9a31e04a0d2eb6140aa893bdcb9.zip
Fixed broken doc generation with USE=-glut (fixes bug #200914).
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'sci-mathematics/yacas')
-rw-r--r--sci-mathematics/yacas/ChangeLog6
-rw-r--r--sci-mathematics/yacas/yacas-1.0.61.ebuild11
-rw-r--r--sci-mathematics/yacas/yacas-1.0.63.ebuild12
-rw-r--r--sci-mathematics/yacas/yacas-1.1.0.ebuild3
4 files changed, 20 insertions, 12 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index d8a532cbd591..13c004e660f0 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.18 2007/11/07 23:26:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.19 2007/12/13 11:31:32 markusle Exp $
+
+ 13 Dec 2007; Markus Dittrich <markusle@gentoo.org> yacas-1.0.61.ebuild,
+ yacas-1.0.63.ebuild:
+ Fixed broken doc generation with USE="-glut" (fixes bug #200914).
*yacas-1.2.2 (07 Nov 2007)
diff --git a/sci-mathematics/yacas/yacas-1.0.61.ebuild b/sci-mathematics/yacas/yacas-1.0.61.ebuild
index 1d790bf87554..60785097170a 100644
--- a/sci-mathematics/yacas/yacas-1.0.61.ebuild
+++ b/sci-mathematics/yacas/yacas-1.0.61.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.61.ebuild,v 1.3 2006/04/18 03:59:36 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.61.ebuild,v 1.4 2007/12/13 11:31:32 markusle Exp $
inherit eutils flag-o-matic
@@ -23,9 +23,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
if ! use glut; then
- sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
- sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
+ sed -e "s:opengl::g" -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e "s/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/" -i \
manmake/Makefile.in || die 'sed (manmake) failed'
+ sed -e "s:\*INCLUDE opengl.chapt::" \
+ -i manmake/plugin-docs.chapt.txt \
+ || die "failed to fix plugin-doc.chapt"
fi
}
diff --git a/sci-mathematics/yacas/yacas-1.0.63.ebuild b/sci-mathematics/yacas/yacas-1.0.63.ebuild
index 5e07eb2dad58..1fd79b9213eb 100644
--- a/sci-mathematics/yacas/yacas-1.0.63.ebuild
+++ b/sci-mathematics/yacas/yacas-1.0.63.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.4 2007/07/18 02:16:06 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.5 2007/12/13 11:31:32 markusle Exp $
inherit autotools eutils flag-o-matic
@@ -25,10 +25,13 @@ src_unpack() {
cd "${S}"
if ! use glut; then
- sed -e 's:opengl::g' -i plugins/Makefile.am || \
+ sed -e "s:opengl::g" -i plugins/Makefile.am || \
die "sed (opengl) failed"
- sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
- manmake/Makefile.am || die 'sed (manmake) failed'
+ sed -e "s:\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\):\1 \2:" \
+ -i manmake/Makefile.am || die 'sed (manmake) failed'
+ sed -e "s:\*INCLUDE opengl.chapt::" \
+ -i manmake/plugin-docs.chapt.txt \
+ || die "failed to fix plugin-doc.chapt"
fi
epatch "${FILESDIR}"/${P}-as-needed.patch
@@ -50,7 +53,6 @@ src_compile() {
}
src_install() {
- cd "${S}"
make DESTDIR="${D}" install-strip || die
dodoc AUTHORS INSTALL NEWS README TODO
diff --git a/sci-mathematics/yacas/yacas-1.1.0.ebuild b/sci-mathematics/yacas/yacas-1.1.0.ebuild
index c3daf81d74a2..85c293f45e7a 100644
--- a/sci-mathematics/yacas/yacas-1.1.0.ebuild
+++ b/sci-mathematics/yacas/yacas-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.1.0.ebuild,v 1.1 2007/08/10 18:00:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.1.0.ebuild,v 1.2 2007/12/13 11:31:32 markusle Exp $
inherit autotools eutils flag-o-matic
@@ -50,7 +50,6 @@ src_compile() {
}
src_install() {
- cd "${S}"
make DESTDIR="${D}" install-strip || die
dodoc AUTHORS INSTALL NEWS README TODO