summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-04-18 10:10:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-04-18 10:10:55 +0000
commit15a8adee94c1cc0ddd1e55bda5a87d6f1fe0d235 (patch)
tree764581dc3f22cbe26c74b2505cbc8a44576f5759 /sci-mathematics
parentVersion bump, bug #168765 (diff)
downloadgentoo-2-15a8adee94c1cc0ddd1e55bda5a87d6f1fe0d235.tar.gz
gentoo-2-15a8adee94c1cc0ddd1e55bda5a87d6f1fe0d235.tar.bz2
gentoo-2-15a8adee94c1cc0ddd1e55bda5a87d6f1fe0d235.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog8
-rw-r--r--sci-mathematics/wxmaxima/files/digest-wxmaxima-0.7.23
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild60
3 files changed, 70 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index b3d5157f05a4..0ea867ed40da 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.2 2007/02/23 12:16:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.3 2007/04/18 10:10:55 bicatali Exp $
+
+*wxmaxima-0.7.2 (18 Apr 2007)
+
+ 18 Apr 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +wxmaxima-0.7.2.ebuild:
+ Version bump. Closing bug #174299.
23 Feb 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
changed sci -> sci-mathematics
diff --git a/sci-mathematics/wxmaxima/files/digest-wxmaxima-0.7.2 b/sci-mathematics/wxmaxima/files/digest-wxmaxima-0.7.2
new file mode 100644
index 000000000000..b68a517203a4
--- /dev/null
+++ b/sci-mathematics/wxmaxima/files/digest-wxmaxima-0.7.2
@@ -0,0 +1,3 @@
+MD5 4a0c6099a60d5f54e262cc505d8caca7 wxMaxima-0.7.2.tar.gz 700658
+RMD160 886f8c187aa999cac02d6f4ff6c2275c00bad597 wxMaxima-0.7.2.tar.gz 700658
+SHA256 846c9c39a232e074fdd7e869f21e9e9f4aa21aacfa4559033d064b62e639ef12 wxMaxima-0.7.2.tar.gz 700658
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
new file mode 100644
index 000000000000..1fc0083f0e47
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild,v 1.1 2007/04/18 10:10:55 bicatali Exp $
+
+inherit eutils autotools wxwidgets
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+DEPEND=">=dev-libs/libxml2-2.5.0
+ >=x11-libs/wxGTK-2.6"
+RDEPEND=">=sci-mathematics/maxima-5.11.0"
+
+S=${WORKDIR}/${MYP}
+
+src_compile () {
+ export WX_GTK_VER="2.6"
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+
+ # consistent package names
+ sed -i \
+ -e 's:COPYING::' \
+ -e "s:${datadir}/wxMaxima:${datadir}/${PN}:g" \
+ Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -i \
+ -e 's:share/wxMaxima:share/wxmaxima:g' \
+ src/wxMaxima.cpp || die "sed failed"
+
+ econf \
+ --enable-dnd \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG} \
+ $(use_unicode unicode-glyphs) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/share/pixmaps/
+ newins maxima-new.png wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+
+ dosym ${PORTDIR}/licenses/${LICENSE} /usr/share/${PN}/COPYING
+ dodir /usr/share/doc/${PF}
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}