summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2005-11-08 14:01:07 +0000
committerGeorge Shapovalov <george@gentoo.org>2005-11-08 14:01:07 +0000
commit20f9b4fa976d395ab2233bd59bc00632fc27a9be (patch)
tree572ec486522d0c59bd091ed12f0530362e4b6a09 /sci-mathematics
parentremoved beta version (diff)
downloadgentoo-2-20f9b4fa976d395ab2233bd59bc00632fc27a9be.tar.gz
gentoo-2-20f9b4fa976d395ab2233bd59bc00632fc27a9be.tar.bz2
gentoo-2-20f9b4fa976d395ab2233bd59bc00632fc27a9be.zip
fixed no-optimization issue (#79278) + -fPIC fix
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/ChangeLog5
-rw-r--r--sci-mathematics/pari/Manifest16
-rw-r--r--sci-mathematics/pari/pari-2.1.5-r4.ebuild15
3 files changed, 20 insertions, 16 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 675faebf1d8d..83bf7d7613d1 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.16 2005/09/17 11:23:14 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.17 2005/11/08 14:01:07 george Exp $
+
+ 08 Nov 2005; George Shapovalov <george@gentoo.org> pari-2.1.5-r4.ebuild:
+ fixed no-optimization-given issue (#79278), also added -fPIC fix to this version
07 Jul 2005; George Shapovalov <george@gentoo.org> pari-2.1.6.ebuild:
executables needed -fPIC on amd64, fixed ebuild
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index ee7b7a5cfc73..d3d3d02eec59 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -1,19 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 95d3d69c971b880d9a083f59dcf70bb5 pari-2.1.5-r4.ebuild 2272
-MD5 b280810de2c9996b6da854bc3a813bc7 pari-2.1.6.ebuild 2240
MD5 136ebceb1ba19a812ccd539b7ef60c28 ChangeLog 4991
MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r4 63
MD5 2fd9906f2bf293fdad42d572846508de files/digest-pari-2.1.6 60
MD5 c3f89da5ddbdb73646e3d64ee31ea887 files/docs.patch 915
MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype-r1.patch 1498
MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDK/y3Kf2g/qXtneoRAlcfAJ95Isu5km8HRPsgeoUkkGktr+8KjQCgqWEu
-NeX/JdbIL/IuISmpebQ2ha0=
-=Hfum
------END PGP SIGNATURE-----
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 b26429df4a7fc3a9c6f4c865e3f412ad pari-2.1.5-r4.ebuild 2520
+MD5 b280810de2c9996b6da854bc3a813bc7 pari-2.1.6.ebuild 2240
diff --git a/sci-mathematics/pari/pari-2.1.5-r4.ebuild b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
index 85ce1a661107..8f6d00486b8c 100644
--- a/sci-mathematics/pari/pari-2.1.5-r4.ebuild
+++ b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r4.ebuild,v 1.2 2005/06/26 13:49:26 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r4.ebuild,v 1.3 2005/11/08 14:01:07 george Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
HOMEPAGE="http://www.parigp-home.de/"
@@ -21,9 +21,20 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/docs.patch
epatch ${FILESDIR}/wrong_functype.patch
+
}
src_compile() {
+ #need to force optimization here, as it breaks without
+ if is-flag -O0; then
+ replace-flags -O0 -O2
+ elif ! is-flag -O?; then
+ append-flags -O2
+ fi
+
+ #we also need to force -fPIC
+ if ! is-flag -fPIC; then append-flags -fPIC; fi
+
./Configure \
--host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
--prefix=/usr \