summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-08-06 18:36:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-08-06 18:36:10 +0000
commitd3cfb8ae21f235edbe8715bcb6921f4400a45bf5 (patch)
tree6821304fbaa937977db90bc0dd1dd7115f843416 /sci-mathematics
parentadd ~arm, bug #476124 (diff)
downloadgentoo-2-d3cfb8ae21f235edbe8715bcb6921f4400a45bf5.tar.gz
gentoo-2-d3cfb8ae21f235edbe8715bcb6921f4400a45bf5.tar.bz2
gentoo-2-d3cfb8ae21f235edbe8715bcb6921f4400a45bf5.zip
Version bump
(Portage version: 2.2.01.22124-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pspp/ChangeLog11
-rw-r--r--sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch11
-rw-r--r--sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch10
-rw-r--r--sci-mathematics/pspp/pspp-0.8.0.ebuild89
4 files changed, 119 insertions, 2 deletions
diff --git a/sci-mathematics/pspp/ChangeLog b/sci-mathematics/pspp/ChangeLog
index 04d4532ec742..f75bdc642d15 100644
--- a/sci-mathematics/pspp/ChangeLog
+++ b/sci-mathematics/pspp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/pspp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.22 2012/12/30 17:47:06 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.23 2013/08/06 18:36:10 bicatali Exp $
+
+*pspp-0.8.0 (06 Aug 2013)
+
+ 06 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/pspp-0.8.0-as-needed.patch, +files/pspp-0.8.0-gettext.patch,
+ +pspp-0.8.0.ebuild:
+ Version bump
30 Dec 2012; Thomas Kahle <tomka@gentoo.org> pspp-0.6.2-r1.ebuild:
Fix doc install per bug 449312
diff --git a/sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch b/sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch
new file mode 100644
index 000000000000..e8d7a2ab675a
--- /dev/null
+++ b/sci-mathematics/pspp/files/pspp-0.8.0-as-needed.patch
@@ -0,0 +1,11 @@
+--- src/ui/terminal/automake.mk.orig 2013-08-06 09:28:53.517642699 -0700
++++ src/ui/terminal/automake.mk 2013-08-06 10:04:37.403409602 -0700
+@@ -24,7 +24,7 @@
+ src/libpspp-core.la \
+ $(CAIRO_LIBS) \
+ $(NCURSES_LIBS) \
+- $(LIBREADLINE) \
++ $(LTLIBREADLINE) \
+ $(GSL_LIBS)
+
+
diff --git a/sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch b/sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch
new file mode 100644
index 000000000000..73fb8dc8790a
--- /dev/null
+++ b/sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2013-08-06 10:18:37.329909242 -0700
++++ configure.ac 2013-08-06 10:18:51.011975942 -0700
+@@ -30,6 +30,7 @@
+
+ dnl Disable automatic po/ support, because PSPP provides its own po/ support.
+ AC_PROVIDE([AM_PO_SUBDIRS])
++AM_GNU_GETTEXT_VERSION([0.17])
+ AM_GNU_GETTEXT([external], [need-ngettext])
+ LIBS="$LIBINTL $LIBS"
+
diff --git a/sci-mathematics/pspp/pspp-0.8.0.ebuild b/sci-mathematics/pspp/pspp-0.8.0.ebuild
new file mode 100644
index 000000000000..718fd27a7cf5
--- /dev/null
+++ b/sci-mathematics/pspp/pspp-0.8.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.8.0.ebuild,v 1.1 2013/08/06 18:36:10 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils elisp-common autotools-utils multilib
+
+DESCRIPTION="Program for statistical analysis of sampled data"
+HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="cairo doc emacs examples gtk ncurses nls perl postgres static-libs"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ sci-libs/gsl
+ sys-devel/gettext
+ sys-libs/readline
+ sys-libs/zlib
+ virtual/libiconv
+ cairo? ( x11-libs/cairo )
+ emacs? ( virtual/emacs )
+ gtk? ( x11-libs/gtk+:2 gnome-base/libglade:2.0 )
+ ncurses? ( sys-libs/ncurses )
+ postgres? ( dev-db/postgresql-server )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+SITEFILE=50${PN}-gentoo.el
+
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-as-needed.patch
+ "${FILESDIR}"/${PN}-0.8.0-gettext.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ $(use_with cairo)
+ $(use_with gtk gui)
+ $(use_with ncurses libncurses)
+ $(use_with perl perl-module)
+ $(use_with postgres libpq)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile pkglibdir="${EPREFIX}/usr/$(get_libdir)"
+ use doc && emake html pdf
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ autotools-utils_src_install pkglibdir="${EPREFIX}/usr/$(get_libdir)"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ if use doc; then
+ dohtml -r doc/pspp{,-dev}.html
+ dodoc doc/pspp{,-dev}.pdf
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst () {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}