summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-08-25 22:41:55 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-08-25 22:41:55 +0000
commit18b484af8fbc74e4ea320ba095a9bf54a37a23a8 (patch)
tree1e6e57c35740116f939202c98c2d90a8a96da972 /sci-physics/espresso++
parentSecurity cleanup wrt bug 506640 (diff)
downloadgentoo-2-18b484af8fbc74e4ea320ba095a9bf54a37a23a8.tar.gz
gentoo-2-18b484af8fbc74e4ea320ba095a9bf54a37a23a8.tar.bz2
gentoo-2-18b484af8fbc74e4ea320ba095a9bf54a37a23a8.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics/espresso++')
-rw-r--r--sci-physics/espresso++/ChangeLog7
-rw-r--r--sci-physics/espresso++/espresso++-1.8.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
index 1be25c5abb4d..a767971eef47 100644
--- a/sci-physics/espresso++/ChangeLog
+++ b/sci-physics/espresso++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/espresso++
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.8 2014/06/21 17:35:12 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.9 2014/08/25 22:41:55 ottxor Exp $
+
+*espresso++-1.8.1 (25 Aug 2014)
+
+ 25 Aug 2014; Christoph Junghans <ottxor@gentoo.org> +espresso++-1.8.1.ebuild:
+ version bump
21 Jun 2014; Christoph Junghans <ottxor@gentoo.org> espresso++-1.6.0.ebuild:
added missing dep (bug #514084)
diff --git a/sci-physics/espresso++/espresso++-1.8.1.ebuild b/sci-physics/espresso++/espresso++-1.8.1.ebuild
new file mode 100644
index 000000000000..6ba3853cd6da
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.8.1.ebuild,v 1.1 2014/08/25 22:41:55 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib python-single-r1
+
+DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
+HOMEPAGE="https://www.espresso-pp.de"
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}"
+ EHG_REVISION="default"
+ inherit mercurial
+ KEYWORDS=
+else
+ inherit vcs-snapshot
+ #SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN//+/p}-${PV}.tgz"
+ SRC_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ dev-python/mpi4py"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DLIB="$(get_libdir)"
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}