summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-10 00:08:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-10 00:08:23 +0000
commite98f902c979bda3c3e103a56b140311352ea4312 (patch)
treea6c6337bbbffcdd254cd1add571a3913719ec3b5 /sci-physics/root/files
parentAdded pch local use flag for sci-physics/root (diff)
downloadgentoo-2-e98f902c979bda3c3e103a56b140311352ea4312.tar.gz
gentoo-2-e98f902c979bda3c3e103a56b140311352ea4312.tar.bz2
gentoo-2-e98f902c979bda3c3e103a56b140311352ea4312.zip
Added various patches: one to respect flags in xrootd (needed for afs), one to properly handle -truetype without libXft (bug #204725) and last one for postgresql (bug #203015). Added pch use flag for faster compilation with g++
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-5.16.00-flags.patch13
-rw-r--r--sci-physics/root/files/root-5.16.00-postgres.patch24
-rw-r--r--sci-physics/root/files/root-5.16.00-xft.patch24
3 files changed, 61 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-5.16.00-flags.patch b/sci-physics/root/files/root-5.16.00-flags.patch
new file mode 100644
index 000000000000..05bf8e7531f8
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-flags.patch
@@ -0,0 +1,13 @@
+--- xrootd/config/GNUmake.env.in.orig 2007-12-13 09:23:25.041447494 +0000
++++ xrootd/config/GNUmake.env.in 2007-12-13 09:24:10.056012728 +0000
+@@ -22,8 +22,8 @@
+ LIBDIR = ../../lib$(ARCHDIR)
+ OBJDIR = ../../obj$(ARCHDIR)
+
+-CFLAGS = $(CF64) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
+-CFLAGS32 = $(CF32) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
++CFLAGS = $(CF64) $(OPTFLAGS) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
++CFLAGS32 = $(CF32) $(OPTFLAGS) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
+
+ # Extra flags
+ CFTRACE = @tracedbg@
diff --git a/sci-physics/root/files/root-5.16.00-postgres.patch b/sci-physics/root/files/root-5.16.00-postgres.patch
new file mode 100644
index 000000000000..9e48819fe743
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-postgres.patch
@@ -0,0 +1,24 @@
+--- ./pgsql/src/TPgSQLServer.cxx~ 2007-06-08 18:45:02.000000000 +0900
++++ ./pgsql/src/TPgSQLServer.cxx 2007-12-22 22:41:25.000000000 +0900
+@@ -344,16 +344,16 @@
+ SetError(-1, "cannot allocate PGSQL_STMT" , "Statement");
+ return 0;
+ }
+- stmt->conn=fPgSQL;
+- stmt->res=PQprepare(fPgSQL,"", sql,0,(const Oid*)0);
++ stmt->fConn=fPgSQL;
++ stmt->fRes=PQprepare(fPgSQL,"", sql,0,(const Oid*)0);
+
+- ExecStatusType stat = PQresultStatus(stmt->res);
++ ExecStatusType stat = PQresultStatus(stmt->fRes);
+ if (pgsql_success(stat)) {
+ fErrorOut=stat;
+ return new TPgSQLStatement(stmt, fErrorOut);
+ } else {
+- SetError(stat, PQresultErrorMessage(stmt->res), "Statement");
+- stmt->conn = 0;
++ SetError(stat, PQresultErrorMessage(stmt->fRes), "Statement");
++ stmt->fConn = 0;
+ delete stmt;
+ return 0;
+ }
diff --git a/sci-physics/root/files/root-5.16.00-xft.patch b/sci-physics/root/files/root-5.16.00-xft.patch
new file mode 100644
index 000000000000..cc0055f5f81a
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-xft.patch
@@ -0,0 +1,24 @@
+--- config/Makefile.in.orig 2007-12-12 22:41:28.000000000 +0000
++++ config/Makefile.in 2007-12-12 22:45:27.000000000 +0000
+@@ -36,6 +36,7 @@
+ X11LIBDIR := @x11libdir@
+ XPMLIBDIR := @xpmlibdir@
+ XPMLIB := @xpmlib@
++XFTLIB := @enable_xft@
+
+ EXCEPTIONS := @exceptions@
+ EXPLICITLINK := @explicitlink@
+--- x11ttf/Module.mk.orig 2008-01-09 01:13:23.000000000 +0000
++++ x11ttf/Module.mk 2008-01-09 10:20:00.000000000 +0000
+@@ -31,9 +31,9 @@
+ ALLLIBS += $(X11TTFLIB)
+ ALLMAPS += $(X11TTFMAP)
+
+-#ifeq ($(XFTLIB),yes)
++ifeq ($(XFTLIB),yes)
+ XLIBS += $(X11LIBDIR) -lXft
+-#endif
++endif
+
+ # include all dependency files
+ INCLUDEFILES += $(X11TTFDEP)