summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-19 05:44:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-19 05:44:31 +0000
commit4ca0748bc70e9067c0a67d77c9df349962985d46 (patch)
treea0ec2cdb58a1a961e72974a486ca6580cf6487f5 /sci-physics/root
parentVersion bump to include license fix. (diff)
downloadgentoo-2-4ca0748bc70e9067c0a67d77c9df349962985d46.tar.gz
gentoo-2-4ca0748bc70e9067c0a67d77c9df349962985d46.tar.bz2
gentoo-2-4ca0748bc70e9067c0a67d77c9df349962985d46.zip
Forbid as-needed (bug #287178), fixed a syntax while installing TMVA documentation, new version bump with new set of patches. Thanks Andrew Savchenko for his contribution.
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/ChangeLog11
-rw-r--r--sci-physics/root/root-5.22.00-r2.ebuild8
-rw-r--r--sci-physics/root/root-5.22.00-r3.ebuild6
-rw-r--r--sci-physics/root/root-5.24.00-r1.ebuild (renamed from sci-physics/root/root-5.24.00.ebuild)15
4 files changed, 27 insertions, 13 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index f722d4cf89a1..ca140383f2f0 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.57 2009/10/06 17:46:39 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.58 2009/11/19 05:44:31 bicatali Exp $
+
+*root-5.24.00-r1 (19 Nov 2009)
+
+ 19 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ root-5.22.00-r2.ebuild, root-5.22.00-r3.ebuild, -root-5.24.00.ebuild,
+ +root-5.24.00-r1.ebuild:
+ Forbid as-needed (bug #287178), fixed a syntax while installing TMVA
+ documentation, new version bump with new set of patches. Thanks Andrew
+ Savchenko for his contribution.
06 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> root-5.22.00-r2.ebuild,
root-5.22.00-r3.ebuild, root-5.24.00.ebuild:
diff --git a/sci-physics/root/root-5.22.00-r2.ebuild b/sci-physics/root/root-5.22.00-r2.ebuild
index 8cbbce228e5c..ed6be3ac99ff 100644
--- a/sci-physics/root/root-5.22.00-r2.ebuild
+++ b/sci-physics/root/root-5.22.00-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.22.00-r2.ebuild,v 1.5 2009/10/06 17:46:39 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.22.00-r2.ebuild,v 1.6 2009/11/19 05:44:31 bicatali Exp $
EAPI=2
-inherit versionator eutils qt4 fortran elisp-common fdo-mime toolchain-funcs
+inherit versionator eutils qt4 fortran elisp-common fdo-mime toolchain-funcs flag-o-matic
#DOC_PV=$(get_major_version)_$(get_version_component_range 2)
DOC_PV=5_21
@@ -105,6 +105,8 @@ pkg_setup() {
export USE_OPENMP=1
use math && export USE_PARALLEL_MINUIT2=1
fi
+ # bug #287178
+ append-ldflags $(no-as-needed)
}
src_prepare() {
@@ -223,7 +225,7 @@ doc_install() {
insinto /usr/share/doc/${PF}
doins \
"${DISTDIR}"/Users_Guide_${DOC_PV}.pdf \
- "${DISTDIR}"/TMVAUsersGuide_v${TMVA_DOC_PV}.pdf \
+ "${DISTDIR}"/TMVAUsersGuide-v${TMVA_DOC_PV}.pdf \
|| die "pdf install failed"
if use math; then
doins "${DISTDIR}"/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf \
diff --git a/sci-physics/root/root-5.22.00-r3.ebuild b/sci-physics/root/root-5.22.00-r3.ebuild
index ea8af7661430..0104bccfb072 100644
--- a/sci-physics/root/root-5.22.00-r3.ebuild
+++ b/sci-physics/root/root-5.22.00-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.22.00-r3.ebuild,v 1.2 2009/10/06 17:46:39 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.22.00-r3.ebuild,v 1.3 2009/11/19 05:44:31 bicatali Exp $
EAPI=2
inherit versionator eutils qt4 elisp-common fdo-mime toolchain-funcs
@@ -106,6 +106,8 @@ pkg_setup() {
ewarn "switch to an older gcc version or another compiler"
die "cint7 incompatible with gcc>4"
fi
+ # bug #287178
+ append-ldflags $(no-as-needed)
}
src_prepare() {
@@ -226,7 +228,7 @@ doc_install() {
insinto /usr/share/doc/${PF}
doins \
"${DISTDIR}"/Users_Guide_${DOC_PV}.pdf \
- "${DISTDIR}"/TMVAUsersGuide_v${TMVA_DOC_PV}.pdf \
+ "${DISTDIR}"/TMVAUsersGuide-v${TMVA_DOC_PV}.pdf \
|| die "pdf install failed"
if use math; then
doins "${DISTDIR}"/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf \
diff --git a/sci-physics/root/root-5.24.00.ebuild b/sci-physics/root/root-5.24.00-r1.ebuild
index 7734bc2d071e..35a564ccb589 100644
--- a/sci-physics/root/root-5.24.00.ebuild
+++ b/sci-physics/root/root-5.24.00-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.24.00.ebuild,v 1.2 2009/10/06 17:46:39 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.24.00-r1.ebuild,v 1.1 2009/11/19 05:44:31 bicatali Exp $
EAPI=2
-inherit versionator eutils qt4 elisp-common fdo-mime toolchain-funcs
+inherit versionator eutils qt4 elisp-common fdo-mime toolchain-funcs flag-o-matic
DOC_PV=$(get_major_version)_$(get_version_component_range 2)
ROOFIT_DOC_PV=2.91-33
TMVA_DOC_PV=4
-PATCH_PV=p01
+PATCH_PV=p02
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
SRC_URI="ftp://root.cern.ch/${PN}/${PN}_v${PV}.source.tar.gz
@@ -98,16 +98,17 @@ pkg_setup() {
export USE_OPENMP=1
use math && export USE_PARALLEL_MINUIT2=1
fi
+ # bug #287178
+ append-ldflags $(no-as-needed)
}
src_prepare() {
+ epatch "${WORKDIR}"/${P}-svn31303.patch
epatch "${WORKDIR}"/${P}-gcc44.patch
- epatch "${WORKDIR}"/${P}-svn30106.patch
epatch "${WORKDIR}"/${P}-prop-flags.patch
- epatch "${WORKDIR}"/${P}-as-needed.patch
epatch "${WORKDIR}"/${P}-xrootd-prop-flags.patch
+ epatch "${WORKDIR}"/${P}-as-needed.patch
epatch "${WORKDIR}"/${P}-configure-paths.patch
- epatch "${WORKDIR}"/${P}-configure-sandbox.patch
epatch "${WORKDIR}"/${P}-g4root-flags.patch
# use system cfortran
@@ -215,7 +216,7 @@ doc_install() {
insinto /usr/share/doc/${PF}
doins \
"${DISTDIR}"/Users_Guide_${DOC_PV}.pdf \
- "${DISTDIR}"/TMVAUsersGuide_v${TMVA_DOC_PV}.pdf \
+ "${DISTDIR}"/TMVAUsersGuide-v${TMVA_DOC_PV}.pdf \
|| die "pdf install failed"
if use math; then
doins "${DISTDIR}"/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf \