summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-01-30 21:00:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-01-30 21:00:20 +0000
commit3d3c50de9eb6926213abf9b6695a2fac766d2f18 (patch)
tree97163dbf566178fb5afa631f6284a52707f960eb /sci-physics
parentVersion bump, bug #349644 (diff)
downloadgentoo-2-3d3c50de9eb6926213abf9b6695a2fac766d2f18.tar.gz
gentoo-2-3d3c50de9eb6926213abf9b6695a2fac766d2f18.tar.bz2
gentoo-2-3d3c50de9eb6926213abf9b6695a2fac766d2f18.zip
Added more upstream fixes. Switched to EAPI=4. Added static-libs flag, force octave flag to depend on C++ wrappers (bug #352055).
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/ChangeLog9
-rw-r--r--sci-physics/lhapdf/lhapdf-5.8.4-r1.ebuild81
-rw-r--r--sci-physics/lhapdf/lhapdf-5.8.4.ebuild13
3 files changed, 97 insertions, 6 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index c42b0614e2a4..98755fe72e98 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.14 2011/01/20 12:16:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.15 2011/01/30 21:00:20 bicatali Exp $
+
+*lhapdf-5.8.4-r1 (30 Jan 2011)
+
+ 30 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org> lhapdf-5.8.4.ebuild,
+ +lhapdf-5.8.4-r1.ebuild:
+ Added more upstream fixes. Switched to EAPI=4. Added static-libs flag, force
+ octave flag to depend on C++ wrappers (bug #352055).
20 Jan 2011; Markos Chandras <hwoarang@gentoo.org> lhapdf-5.8.4.ebuild:
Stable on amd64 wrt bug #352055
diff --git a/sci-physics/lhapdf/lhapdf-5.8.4-r1.ebuild b/sci-physics/lhapdf/lhapdf-5.8.4-r1.ebuild
new file mode 100644
index 000000000000..aa4a5c0eef95
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-5.8.4-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.4-r1.ebuild,v 1.1 2011/01/30 21:00:20 bicatali Exp $
+
+EAPI=4
+
+inherit versionator eutils
+
+MY_PV=$(get_version_component_range 1-3 ${PV})
+MY_PF=${PN}-${MY_PV}
+MY_UV=20110126
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://projects.hepforge.org/lhapdf/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz
+ mirror://gentoo/${P}-updates-${MY_UV}.patch.gz
+ test? (
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq61.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/MRST2004nlo.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq61.LHpdf
+ octave? ( http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq5l.LHgrid ) )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx doc examples octave python static-libs test"
+REQUIRED_USE="octave? ( cxx )"
+RDEPEND="octave? ( sci-mathematics/octave )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )
+ python? ( dev-lang/swig )"
+
+S="${WORKDIR}/${MY_PF}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-updates-${MY_UV}.patch
+ # do not create extra latex docs
+ sed -i \
+ -e 's/GENERATE_LATEX.*=YES/GENERATE_LATEX = NO/g' \
+ ccwrap/Doxyfile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable cxx ccwrap) \
+ $(use_enable cxx old-ccwrap ) \
+ $(use_enable doc doxygen) \
+ $(use_enable octave) \
+ $(use_enable python pyext) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # need to make a bogus link for octave test
+ ln -s "${DISTDIR}" PDFsets
+ LHAPATH="${PWD}/PDFsets" \
+ LD_LIBRARY_PATH="${PWD}/lib/.libs:${LD_LIBRARY_PATH}" \
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO AUTHORS ChangeLog
+
+ # leftover
+ rm -rf "${D}"/usr/share/${PN}/doc || die
+ if use doc && use cxx; then
+ # default doc install buggy
+ insinto /usr/share/doc/${PF}
+ doins -r ccwrap/doxy/html || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.{f,cc} || die
+ fi
+}
+
+pkg_postinst() {
+ elog "To install data files, you have to run as root:"
+ elog "lhapdf-getdata --dest=${EROOT}usr/share/lhapdf --all"
+}
diff --git a/sci-physics/lhapdf/lhapdf-5.8.4.ebuild b/sci-physics/lhapdf/lhapdf-5.8.4.ebuild
index fde6c21fe6e2..85f10406f6e1 100644
--- a/sci-physics/lhapdf/lhapdf-5.8.4.ebuild
+++ b/sci-physics/lhapdf/lhapdf-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.4.ebuild,v 1.2 2011/01/20 12:16:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.4.ebuild,v 1.3 2011/01/30 21:00:20 bicatali Exp $
EAPI=2
@@ -34,8 +34,8 @@ S="${WORKDIR}/${MY_PF}"
src_unpack() {
unpack ${MY_PF}.tar.gz
- mv "${DISTDIR}"/wrapheragrid.f "${WORKDIR}/${MY_PF}"/src/wrapheragrid.f
- mv "${DISTDIR}"/wrapheragrid-lite.f "${WORKDIR}/${MY_PF}"/src/wrapheragrid-lite.f
+ cp "${DISTDIR}"/wrapheragrid.f "${S}"/src/wrapheragrid.f
+ cp "${DISTDIR}"/wrapheragrid-lite.f "${S}"/src/wrapheragrid-lite.f
}
src_prepare() {
@@ -46,11 +46,14 @@ src_prepare() {
}
src_configure() {
+ local myconf="--enable-ccwrap"
+ ! use octave && ! use cxx && myconf="--disable-ccwrap"
econf \
- $(use_enable cxx ccwrap) \
$(use_enable cxx old-ccwrap ) \
+ $(use_enable octave) \
$(use_enable python pyext) \
- $(use_enable doc doxygen)
+ $(use_enable doc doxygen) \
+ ${myconf}
}
src_test() {