summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-03-16 16:11:55 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-03-16 16:11:55 +0000
commit627ea253c52d4ab4f5aa64bb06aa0a19c5122020 (patch)
tree98eccfe811d786ae70733166903c4909d1268b78 /sci-physics
parentVersion bump with minor bugfixes. (diff)
downloadgentoo-2-627ea253c52d4ab4f5aa64bb06aa0a19c5122020.tar.gz
gentoo-2-627ea253c52d4ab4f5aa64bb06aa0a19c5122020.tar.bz2
gentoo-2-627ea253c52d4ab4f5aa64bb06aa0a19c5122020.zip
fixed build with cython-0.22 (bug #543136)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/ChangeLog6
-rw-r--r--sci-physics/espresso/espresso-3.3.0.ebuild3
-rw-r--r--sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch23
3 files changed, 30 insertions, 2 deletions
diff --git a/sci-physics/espresso/ChangeLog b/sci-physics/espresso/ChangeLog
index 7464f423e91e..e9ecf11924f3 100644
--- a/sci-physics/espresso/ChangeLog
+++ b/sci-physics/espresso/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/espresso
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.18 2015/03/07 23:40:50 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.19 2015/03/16 16:11:55 ottxor Exp $
+
+ 16 Mar 2015; Christoph Junghans <ottxor@gentoo.org>
+ +files/espresso-3.3.0-cython-0.22.patch, espresso-3.3.0.ebuild:
+ fixed build with cython-0.22 (bug #543136)
07 Mar 2015; Christoph Junghans <ottxor@gentoo.org> espresso-3.2.0.ebuild,
espresso-3.3.0.ebuild:
diff --git a/sci-physics/espresso/espresso-3.3.0.ebuild b/sci-physics/espresso/espresso-3.3.0.ebuild
index 56feee77c7d7..63f96f7eba64 100644
--- a/sci-physics/espresso/espresso-3.3.0.ebuild
+++ b/sci-physics/espresso/espresso-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.3.0.ebuild,v 1.2 2015/03/07 23:40:50 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.3.0.ebuild,v 1.3 2015/03/16 16:11:55 ottxor Exp $
EAPI=5
@@ -53,6 +53,7 @@ DEPEND="${RDEPEND}
virtual/latex-base )"
DOCS=( AUTHORS NEWS README ChangeLog )
+PATCHES=( "${FILESDIR}/${P}-cython-0.22.patch" )
pkg_setup() {
use python && python-single-r1_pkg_setup
diff --git a/sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch b/sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch
new file mode 100644
index 000000000000..22b726b480e1
--- /dev/null
+++ b/sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch
@@ -0,0 +1,23 @@
+From 9e6caa3294b0f5f377c16550a07429b73c871ac3 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@votca.org>
+Date: Thu, 12 Mar 2015 08:55:51 -0600
+Subject: [PATCH] fix build with cython-0.22
+
+---
+ src/python/espressomd/particle_data.pxd | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/espressomd/particle_data.pxd b/src/python/espressomd/particle_data.pxd
+index fff022b..4cc39e8 100644
+--- a/src/python/espressomd/particle_data.pxd
++++ b/src/python/espressomd/particle_data.pxd
+@@ -185,5 +185,5 @@ cdef class ParticleHandle(object):
+ cdef public int id
+ cdef bint valid
+ cdef Particle particleData
+- cdef int updateParticleData(self)
++ cdef int updateParticleData(self) except -1
+
+--
+2.0.5
+