summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 09:55:10 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 09:55:10 +0000
commit8d980ff32784aa36c631291615316ea134c5c803 (patch)
tree9d8cd1dbb3bd0b2c4c5412a725c39acf11f19dc4 /sci-physics
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-8d980ff32784aa36c631291615316ea134c5c803.tar.gz
gentoo-2-8d980ff32784aa36c631291615316ea134c5c803.tar.bz2
gentoo-2-8d980ff32784aa36c631291615316ea134c5c803.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog6
-rw-r--r--sci-physics/root/root-5.26.00-r2.ebuild5
-rw-r--r--sci-physics/root/root-5.26.00e-r1.ebuild5
-rw-r--r--sci-physics/root/root-5.28.00d.ebuild5
4 files changed, 14 insertions, 7 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index cb3a8570414f..bb7cb3bd9acf 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.86 2011/06/06 01:31:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.87 2011/06/21 09:55:10 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> root-5.26.00-r2.ebuild,
+ root-5.26.00e-r1.ebuild, root-5.28.00d.ebuild:
+ Added fortran-2.eclass support
06 Jun 2011; Jeroen Roovers <jer@gentoo.org> root-5.26.00-r2.ebuild,
root-5.26.00e-r1.ebuild:
diff --git a/sci-physics/root/root-5.26.00-r2.ebuild b/sci-physics/root/root-5.26.00-r2.ebuild
index a70bb601aa02..4dcfcbe91f8f 100644
--- a/sci-physics/root/root-5.26.00-r2.ebuild
+++ b/sci-physics/root/root-5.26.00-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00-r2.ebuild,v 1.11 2011/06/06 01:31:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00-r2.ebuild,v 1.12 2011/06/21 09:55:10 jlec Exp $
EAPI=2
-inherit versionator eutils qt4 elisp-common fdo-mime toolchain-funcs flag-o-matic
+inherit versionator eutils fortran-2 qt4 elisp-common fdo-mime toolchain-funcs flag-o-matic
DOC_PV=$(get_major_version)_$(get_version_component_range 2)
ROOFIT_DOC_PV=2.91-33
@@ -75,6 +75,7 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${PN}"
pkg_setup() {
+ fortran-2_pkg_setup
elog
elog "You may want to build ROOT with these non Gentoo extra packages:"
elog "AliEn, castor, Chirp, dCache, gfal, gLite, Globus,"
diff --git a/sci-physics/root/root-5.26.00e-r1.ebuild b/sci-physics/root/root-5.26.00e-r1.ebuild
index fc9b236805e9..096d212b2e0c 100644
--- a/sci-physics/root/root-5.26.00e-r1.ebuild
+++ b/sci-physics/root/root-5.26.00e-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00e-r1.ebuild,v 1.8 2011/06/06 01:31:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00e-r1.ebuild,v 1.9 2011/06/21 09:55:10 jlec Exp $
EAPI=3
PYTHON_DEPEND="python? 2"
-inherit versionator eutils elisp-common fdo-mime python toolchain-funcs
+inherit versionator eutils fortran-2 elisp-common fdo-mime python toolchain-funcs
DOC_PV=$(get_major_version)_$(get_version_component_range 2)
ROOFIT_DOC_PV=2.91-33
@@ -76,6 +76,7 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${PN}"
pkg_setup() {
+ fortran-2_pkg_setup
elog
elog "You may want to build ROOT with these non Gentoo extra packages:"
elog "AliEn, castor, Chirp, dCache, gfal, gLite, Globus,"
diff --git a/sci-physics/root/root-5.28.00d.ebuild b/sci-physics/root/root-5.28.00d.ebuild
index 88f61826b493..56e268795b9c 100644
--- a/sci-physics/root/root-5.28.00d.ebuild
+++ b/sci-physics/root/root-5.28.00d.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.28.00d.ebuild,v 1.1 2011/05/17 18:14:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.28.00d.ebuild,v 1.2 2011/06/21 09:55:10 jlec Exp $
EAPI=3
PYTHON_DEPEND="python? 2"
-inherit versionator eutils elisp-common fdo-mime python toolchain-funcs flag-o-matic
+inherit versionator eutils fortran-2 elisp-common fdo-mime python toolchain-funcs flag-o-matic
#DOC_PV=$(get_major_version)_$(get_version_component_range 2)
DOC_PV=5_26
@@ -82,6 +82,7 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${PN}"
pkg_setup() {
+ fortran-2_pkg_setup
elog
elog "There are extra options on packages not yet in Gentoo:"
elog "AliEn, castor, Chirp, dCache, gfal, gLite, Globus,"