summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:43:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:43:22 +0000
commitaeaba5724044725d1d6e4b18edeee0c9c70f083e (patch)
treec2819c5a4bcbcada59a3806733d2953cc62691a6 /sci-physics
parentVersion bump (diff)
downloadgentoo-2-aeaba5724044725d1d6e4b18edeee0c9c70f083e.tar.gz
gentoo-2-aeaba5724044725d1d6e4b18edeee0c9c70f083e.tar.bz2
gentoo-2-aeaba5724044725d1d6e4b18edeee0c9c70f083e.zip
Version bump
(Portage version: 2.2.10.1-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/ChangeLog7
-rw-r--r--sci-physics/lhapdf/lhapdf-6.1.3.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index 6dd128da2f6c..5318d6bd03c4 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.27 2014/06/10 19:24:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.28 2014/06/30 18:43:22 bicatali Exp $
+
+*lhapdf-6.1.3 (30 Jun 2014)
+
+ 30 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-6.1.3.ebuild:
+ Version bump
*lhapdf-6.1.2 (10 Jun 2014)
diff --git a/sci-physics/lhapdf/lhapdf-6.1.3.ebuild b/sci-physics/lhapdf/lhapdf-6.1.3.ebuild
new file mode 100644
index 000000000000..5758c5d6e65b
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-6.1.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-6.1.3.ebuild,v 1.1 2014/06/30 18:43:22 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit versionator autotools-utils distutils-r1
+
+MY_PV=$(get_version_component_range 1-3 ${PV})
+MY_PF=LHAPDF-${MY_PV}
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://lhapdf.hepforge.org/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:0=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )"
+
+S="${WORKDIR}/${MY_PF}"
+
+src_configure() {
+ autotools-utils_src_configure $(use_enable python)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo doxy)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ autotools-utils_src_compile -C tests
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r doc/doxygen/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cc
+ fi
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_install
+ fi
+}
+
+pkg_postinst() {
+ elog "Download data files from:"
+ elog "http://www.hepforge.org/archive/${PN}/pdfsets/$(get_version_component_range 1-2 ${PV})"
+ elog "and untar them into ${EROOT%/}/usr/share/LHAPDF"
+}