summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2015-04-12 16:00:15 +0000
committerNicolas Bock <nicolasbock@gentoo.org>2015-04-12 16:00:15 +0000
commite9c07d508b9db39ced41c0567f446616d91b2dad (patch)
treeb8ff409dec84517a99142ff02094c8753757f24d /sci-physics
parentVersion bump (diff)
downloadgentoo-2-e9c07d508b9db39ced41c0567f446616d91b2dad.tar.gz
gentoo-2-e9c07d508b9db39ced41c0567f446616d91b2dad.tar.bz2
gentoo-2-e9c07d508b9db39ced41c0567f446616d91b2dad.zip
sci-physics/lammps: added new version.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key AC91CA52)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lammps/ChangeLog7
-rw-r--r--sci-physics/lammps/lammps-20150403.ebuild228
2 files changed, 234 insertions, 1 deletions
diff --git a/sci-physics/lammps/ChangeLog b/sci-physics/lammps/ChangeLog
index 1b07df8d7cc1..3d6cf5e1b9ac 100644
--- a/sci-physics/lammps/ChangeLog
+++ b/sci-physics/lammps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/lammps
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/ChangeLog,v 1.91 2015/04/11 20:43:19 nicolasbock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/ChangeLog,v 1.92 2015/04/12 16:00:15 nicolasbock Exp $
+
+*lammps-20150403 (12 Apr 2015)
+
+ 12 Apr 2015; Nicolas Bock <nicolasbock@gentoo.org> +lammps-20150403.ebuild:
+ sci-physics/lammps: added new version.
*lammps-20150402 (11 Apr 2015)
diff --git a/sci-physics/lammps/lammps-20150403.ebuild b/sci-physics/lammps/lammps-20150403.ebuild
new file mode 100644
index 000000000000..6a2ca9dc4bdf
--- /dev/null
+++ b/sci-physics/lammps/lammps-20150403.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lammps/lammps-20150403.ebuild,v 1.1 2015/04/12 16:00:15 nicolasbock Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic fortran-2 multilib python-r1
+
+convert_month() {
+ case $1 in
+ 01) echo Jan
+ ;;
+ 02) echo Feb
+ ;;
+ 03) echo Mar
+ ;;
+ 04) echo Apr
+ ;;
+ 05) echo May
+ ;;
+ 06) echo Jun
+ ;;
+ 07) echo Jul
+ ;;
+ 08) echo Aug
+ ;;
+ 09) echo Sep
+ ;;
+ 10) echo Oct
+ ;;
+ 11) echo Nov
+ ;;
+ 12) echo Dec
+ ;;
+ *) echo unknown
+ ;;
+ esac
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gzip lammps-memalign mpi python static-libs"
+
+DEPEND="
+ mpi? (
+ virtual/blas
+ virtual/lapack
+ virtual/mpi
+ )
+ gzip? ( app-arch/gzip )
+ sci-libs/voro++
+ python? ( ${PYTHON_DEPS} )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+ local LAMMPS_INCLUDEFLAGS
+ LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+ LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN' '')"
+
+ # The lammps makefile uses CC to indicate the C++ compiler.
+ emake \
+ ARCHIVE=$(tc-getAR) \
+ CC=$(usex mpi "mpic++" "$(tc-getCXX)") \
+ F90=$(usex mpi "mpif90" "$(tc-getFC)") \
+ LINK=$(usex mpi "mpic++" "$(tc-getCXX)") \
+ CCFLAGS="${CXXFLAGS}" \
+ F90FLAGS="${FCFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+ MPI_INC=$(usex mpi "" "-I../STUBS") \
+ MPI_PATH=$(usex mpi "" "-L../STUBS") \
+ MPI_LIB=$(usex mpi "" "-lmpi_stubs") \
+ user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
+ "$@"
+}
+
+lmp_configure() {
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ # Build packages
+ emake -C src yes-asphere
+ emake -C src yes-body
+ emake -C src yes-class2
+ emake -C src yes-colloid
+ emake -C src yes-coreshell
+ emake -C src yes-dipole
+ emake -C src yes-fld
+ #emake -C src yes-gpu
+ emake -C src yes-granular
+ # Need OpenKIM external dependency.
+ #emake -C src yes-kim
+ # Need Kokkos external dependency.
+ #emake -C src yes-kokkos
+ emake -C src yes-kspace
+ emake -C src yes-manybody
+ emake -C src yes-mc
+ lmp_emake -C src yes-meam
+ lmp_emake -j1 -C lib/meam -f Makefile.gfortran
+ emake -C src yes-misc
+ emake -C src yes-molecule
+ #emake -C src yes-mpiio
+ emake -C src yes-opt
+ emake -C src yes-peri
+ emake -C src yes-poems
+ lmp_emake -C lib/poems -f Makefile.g++
+ emake -C src yes-qeq
+ emake -C src yes-reax
+ lmp_emake -j1 -C lib/reax -f Makefile.gfortran
+ emake -C src yes-replica
+ emake -C src yes-rigid
+ emake -C src yes-shock
+ emake -C src yes-snap
+ emake -C src yes-srd
+ emake -C src yes-voronoi
+ emake -C src yes-xtc
+
+ if use mpi; then
+ emake -C src yes-user-atc
+ lmp_emake -C lib/atc -f Makefile.g++
+ fi
+ emake -C src yes-user-eff
+ emake -C src yes-user-fep
+ use mpi && emake -C src yes-user-lb
+ emake -C src yes-user-phonon
+ emake -C src yes-user-sph
+}
+
+src_prepare() {
+ # Fix inconsistent use of SHFLAGS.
+ sed -i \
+ -e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
+ -e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
+ lib/voronoi/Makefile.lammps || die
+
+ # Fix missing .so name.
+ sed -i \
+ -e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
+ src/MAKE/Makefile.serial || die
+
+ # Fix makefile in tools.
+ sed -i \
+ -e 's:g++:$(CXX) $(CXXFLAGS):' \
+ -e 's:gcc:$(CC) $(CCFLAGS):' \
+ -e 's:ifort:$(FC) $(FCFLAGS):' \
+ tools/Makefile || die
+
+ # Add a python shebang.
+ epatch "${FILESDIR}/python-shebang.patch"
+}
+
+src_compile() {
+ # The build system does not rebuild the packages with -fPIC.
+ append-cxxflags -fPIC -I../../src
+ append-fflags -fPIC
+
+ # Acticate packages.
+ lmp_configure
+
+ if use static-libs; then
+ # Build static library.
+ lmp_emake -C src mode=lib serial
+ fi
+
+ # Build shared library.
+ lmp_emake -C src mode=shlib serial
+
+ # Compile main executable. The shared library is always built, and
+ # mode=shexe is simply a way to re-use the object files built in the
+ # "shlib" step when linking the executable. The executable is not actually
+ # using the shared library.
+ lmp_emake -C src mode=shexe serial
+
+ # Compile tools.
+ emake -C tools binary2txt chain data2xmovie micelle2d
+}
+
+src_install() {
+ use static-libs && newlib.a src/liblammps_serial.a liblammps.a
+ newlib.so src/liblammps_serial.so liblammps.so.0.0.0
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
+ newbin src/lmp_serial lmp
+ dobin tools/binary2txt
+ dobin tools/chain
+ dobin tools/data2xmovie
+ dobin tools/micelle2d
+ # Don't forget to add header files of optional packages as they are added
+ # to this ebuild. There may also be .mod files from Fortran based
+ # packages.
+ insinto "/usr/include/${PN}"
+ doins -r src/*.h lib/meam/*.mod
+
+ local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
+ insinto "/${LAMMPS_POTENTIALS}"
+ doins potentials/*
+ echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
+ doenvd 99lammps
+
+ # Install python script.
+ use python && python_foreach_impl python_domodule python/lammps.py
+
+ if use examples; then
+ local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ insinto "${LAMMPS_EXAMPLES}"
+ doins -r examples/*
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/Manual.pdf
+ dohtml -r doc/*
+ fi
+}