summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-06 17:40:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-06 17:40:58 +0000
commitfd109626f4b44bef7a4b2c9324e1ad2c6d58ed19 (patch)
tree6e2a5c6f977e7c1787bb994bcff9bb306107d7c2 /sci-physics
parentInitial commit. (diff)
downloadgentoo-2-fd109626f4b44bef7a4b2c9324e1ad2c6d58ed19.tar.gz
gentoo-2-fd109626f4b44bef7a4b2c9324e1ad2c6d58ed19.tar.bz2
gentoo-2-fd109626f4b44bef7a4b2c9324e1ad2c6d58ed19.zip
UDe-bundle siscone again
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet/ChangeLog8
-rw-r--r--sci-physics/fastjet/fastjet-3.0.6-r1.ebuild (renamed from sci-physics/fastjet/fastjet-3.0.6.ebuild)10
-rw-r--r--sci-physics/fastjet/files/fastjet-3.0.6-system-siscone.patch74
3 files changed, 88 insertions, 4 deletions
diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
index 13a56f09be25..52d166cc63c0 100644
--- a/sci-physics/fastjet/ChangeLog
+++ b/sci-physics/fastjet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/fastjet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.8 2014/02/23 02:46:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.9 2014/05/06 17:40:58 bicatali Exp $
+
+*fastjet-3.0.6-r1 (06 May 2014)
+
+ 06 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +fastjet-3.0.6-r1.ebuild,
+ +files/fastjet-3.0.6-system-siscone.patch, -fastjet-3.0.6.ebuild:
+ UDe-bundle siscone again
*fastjet-3.0.6 (23 Feb 2014)
diff --git a/sci-physics/fastjet/fastjet-3.0.6.ebuild b/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
index 289ca8f8ec20..527c8efd9f65 100644
--- a/sci-physics/fastjet/fastjet-3.0.6.ebuild
+++ b/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.6.ebuild,v 1.1 2014/02/23 02:46:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild,v 1.1 2014/05/06 17:40:58 bicatali Exp $
EAPI=5
FORTRAN_NEEDED=plugins
+AUTOTOOLS_AUTORECONF=1
inherit autotools-utils fortran-2 flag-o-matic
@@ -20,10 +21,13 @@ IUSE="cgal doc examples +plugins static-libs"
RDEPEND="cgal? ( sci-mathematics/cgal )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
- plugins? ( sci-physics/siscone )"
+ plugins? ( sci-physics/siscone:0= )"
+
+PATCHES=( "${FILESDIR}"/${P}-system-siscone.patch )
src_configure() {
- use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
+ use cgal && \
+ has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
local myeconfargs=(
$(use_enable cgal)
$(use_enable plugins allplugins)
diff --git a/sci-physics/fastjet/files/fastjet-3.0.6-system-siscone.patch b/sci-physics/fastjet/files/fastjet-3.0.6-system-siscone.patch
new file mode 100644
index 000000000000..d3995473fe54
--- /dev/null
+++ b/sci-physics/fastjet/files/fastjet-3.0.6-system-siscone.patch
@@ -0,0 +1,74 @@
+diff -Nur fastjet-3.0.6.orig/configure.ac fastjet-3.0.6/configure.ac
+--- fastjet-3.0.6.orig/configure.ac 2014-05-06 10:29:55.240632504 -0700
++++ fastjet-3.0.6/configure.ac 2014-05-06 10:36:20.156246416 -0700
+@@ -261,6 +261,12 @@
+ fi
+
+ dnl SISCone
++AC_ARG_WITH(bundle-siscone,
++ [ --with-bundle-siscone Build the bundled SISCone library [default=no]],
++ [bundle_siscone=$withval],
++ [bundle_siscone=no])
++AM_CONDITIONAL(BUNDLE_SISCONE, test x$bundle_siscone != xno)
++
+ ACX_CHECK_PLUGIN(SISCone, siscone, SISCONE, yes,
+ [CONFIG_LIBS_PLUGINS=${CONFIG_LIBS_PLUGINS}" -lsiscone_spherical -lsiscone"
+ CONFIG_LIBS_PLUGINS_STATIC=${CONFIG_LIBS_PLUGINS_STATIC}" \${installationdir}/lib/libsiscone.a \${installationdir}/lib/libsiscone_spherical.a"])
+diff -Nur fastjet-3.0.6.orig/example/Makefile.am fastjet-3.0.6/example/Makefile.am
+--- fastjet-3.0.6.orig/example/Makefile.am 2014-05-06 10:29:55.239632499 -0700
++++ fastjet-3.0.6/example/Makefile.am 2014-05-06 10:36:20.156246416 -0700
+@@ -43,7 +43,7 @@
+ 03_plugin_CXXFLAGS = $(AM_CXXFLAGS) $(CGAL_CPPFLAGS) -I$(srcdir)/../include
+ 03_plugin_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ 03_plugin_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ else
+ EXTRA_DIST += 03-plugin.cc
+ endif
+@@ -125,7 +125,7 @@
+ fastjet_areas_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ if BUILD_PLUGIN_SISCONE
+ fastjet_areas_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+
+ fastjet_timing_plugins_SOURCES = fastjet_timing_plugins.cc CmdLine.cc
+@@ -135,7 +135,7 @@
+ fastjet_timing_plugins_LDADD += ../tools/libfastjettools.la
+ if BUILD_PLUGIN_SISCONE
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+ if BUILD_PLUGIN_CDFCONES
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/CDFCones
+diff -Nur fastjet-3.0.6.orig/plugins/SISCone/Makefile.am fastjet-3.0.6/plugins/SISCone/Makefile.am
+--- fastjet-3.0.6.orig/plugins/SISCone/Makefile.am 2014-05-06 10:29:55.250632584 -0700
++++ fastjet-3.0.6/plugins/SISCone/Makefile.am 2014-05-06 10:36:20.156246416 -0700
+@@ -1,11 +1,22 @@
+-SUBDIRS = siscone fastjet .
++SUBDIRS = fastjet .
+
+ if MONOLITHIC_PLUGINS
+ noinst_LTLIBRARIES = libSISConePlugin.la
+ else
+ lib_LTLIBRARIES = libSISConePlugin.la
+ endif
+-libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/siscone -I$(srcdir)/../../include
++libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/../../include
++
++if BUNDLE_SISCONE
++SUBDIRS += siscone
++libSISConePlugin_la_CXXFLAGS += -I$(srcdir)/siscone
++libSISConePlugin_la_LIBADD = \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/libsiscone.la \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++else
++libSISConePlugin_la_LIBADD = -lsiscone -lsiscone_spherical
++endif
++
+ libSISConePlugin_la_SOURCES = SISConePlugin.cc SISConeSphericalPlugin.cc
+
+ EXTRA_DIST = makefile.static