summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-31 06:46:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-31 06:46:20 +0000
commit1ff138b8aab7159faf63f70bd4482378799bd7b7 (patch)
tree8d5713fcd9f6dd70deea535f583fe70cf25af62b /sci-visualization/quickplot
parentCdrom functions have been split out to dedicated cdrom.eclass. For the (diff)
downloadgentoo-2-1ff138b8aab7159faf63f70bd4482378799bd7b7.tar.gz
gentoo-2-1ff138b8aab7159faf63f70bd4482378799bd7b7.tar.bz2
gentoo-2-1ff138b8aab7159faf63f70bd4482378799bd7b7.zip
Version Bump, fixes underlinking
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/quickplot')
-rw-r--r--sci-visualization/quickplot/ChangeLog7
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
index e60a982d73d9..70bd9862b2f7 100644
--- a/sci-visualization/quickplot/ChangeLog
+++ b/sci-visualization/quickplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/quickplot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.14 2012/01/29 13:38:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.15 2012/01/31 06:46:20 jlec Exp $
+
+*quickplot-0.10.3 (31 Jan 2012)
+
+ 31 Jan 2012; Justin Lecher <jlec@gentoo.org> +quickplot-0.10.3.ebuild:
+ Version Bump, fixes underlinking
*quickplot-0.10.2 (29 Jan 2012)
diff --git a/sci-visualization/quickplot/quickplot-0.10.3.ebuild b/sci-visualization/quickplot/quickplot-0.10.3.ebuild
new file mode 100644
index 000000000000..d7586afe1a69
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.10.3.ebuild,v 1.1 2012/01/31 06:46:20 jlec Exp $
+
+EAPI=4
+
+#AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${D}"/usr/share/applications/quickplot*.desktop \
+ "${D}"/usr/share/applications/quickplot.desktop || die
+}