summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-12 08:13:51 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-12 08:13:51 +0000
commitdc907f3349b81048ff6dc02cf54520af2863a295 (patch)
treefcda6f3f003ac36ab2d57d895229819073774f85 /sci-visualization/quickplot
parentVersion bump. Set EAPI=5, add subslot equal major soversion. (diff)
downloadgentoo-2-dc907f3349b81048ff6dc02cf54520af2863a295.tar.gz
gentoo-2-dc907f3349b81048ff6dc02cf54520af2863a295.tar.bz2
gentoo-2-dc907f3349b81048ff6dc02cf54520af2863a295.zip
sci-visualization/quickplot: Version BUmp
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-visualization/quickplot')
-rw-r--r--sci-visualization/quickplot/ChangeLog10
-rw-r--r--sci-visualization/quickplot/metadata.xml4
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.4.ebuild44
3 files changed, 54 insertions, 4 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
index 36b327e7636e..d5e997355d57 100644
--- a/sci-visualization/quickplot/ChangeLog
+++ b/sci-visualization/quickplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/quickplot
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.18 2012/08/07 03:46:47 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.19 2013/03/12 08:13:51 jlec Exp $
+
+*quickplot-0.10.4 (12 Mar 2013)
+
+ 12 Mar 2013; Justin Lecher <jlec@gentoo.org> +quickplot-0.10.4.ebuild,
+ metadata.xml:
+ Version BUmp
07 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
quickplot-0.10.3.ebuild:
diff --git a/sci-visualization/quickplot/metadata.xml b/sci-visualization/quickplot/metadata.xml
index 2308a0885c81..132e9e4fde31 100644
--- a/sci-visualization/quickplot/metadata.xml
+++ b/sci-visualization/quickplot/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription>
+ <herd>sci</herd>
+ <longdescription>
Quickplot is a fast interactive 2D plotter with infinite zooming, value
picking, pipe input, and unlimited plots displayed. Quickplot is meant for
looking at your data quickly and of secondary importance is making static
diff --git a/sci-visualization/quickplot/quickplot-0.10.4.ebuild b/sci-visualization/quickplot/quickplot-0.10.4.ebuild
new file mode 100644
index 000000000000..2ba9273248a1
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.10.4.ebuild,v 1.1 2013/03/12 08:13:51 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed '/libquickplot_la_LIBADD/s:$: -lm:g' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${ED}"/usr/share/applications/quickplot*.desktop \
+ "${ED}"/usr/share/applications/quickplot.desktop || die
+}