summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-10 00:43:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-10 00:43:28 +0000
commitd96a753bb1342f3cdcda8fb7eabdb6f1aab270df (patch)
tree077a257a3f3d2ac509a163318f80dacce287abb4 /sys-apps/attr
parentsed in the right order (Manifest recommit) (diff)
downloadgentoo-2-d96a753bb1342f3cdcda8fb7eabdb6f1aab270df.tar.gz
gentoo-2-d96a753bb1342f3cdcda8fb7eabdb6f1aab270df.tar.bz2
gentoo-2-d96a753bb1342f3cdcda8fb7eabdb6f1aab270df.zip
version bump
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/ChangeLog7
-rw-r--r--sys-apps/attr/attr-2.4.16.ebuild5
-rw-r--r--sys-apps/attr/attr-2.4.19.ebuild62
-rw-r--r--sys-apps/attr/files/digest-attr-2.4.191
4 files changed, 71 insertions, 4 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index 24eeba537b8a..338588d6e52d 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/attr
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.39 2004/09/02 06:39:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.40 2004/10/10 00:43:28 vapier Exp $
+
+*attr-2.4.19 (09 Oct 2004)
+
+ 09 Oct 2004; Mike Frysinger <vapier@gentoo.org> attr-2.4.16.ebuild:
+ Version bump.
01 Sep 2004; Robin H. Johnson <robbat2@gentoo.org> attr-2.4.16.ebuild:
One of the SRC_URI is bad.
diff --git a/sys-apps/attr/attr-2.4.16.ebuild b/sys-apps/attr/attr-2.4.16.ebuild
index a639eb2af9cc..3d92ec68d552 100644
--- a/sys-apps/attr/attr-2.4.16.ebuild
+++ b/sys-apps/attr/attr-2.4.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.16.ebuild,v 1.4 2004/10/10 00:30:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.16.ebuild,v 1.5 2004/10/10 00:43:28 vapier Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 arm hppa ia64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="nls debug static"
+IUSE="nls debug"
DEPEND=">=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4.0.5
@@ -50,7 +50,6 @@ src_compile() {
local LIBDIR="`get_libdir`"
local myconf
myconf="${myconf} `use_enable nls gettext`"
- myconf="${myconf} `use_enable !static shared`"
myconf="${myconf} --libdir=/${LIBDIR} --libexecdir=/usr/${LIBDIR} --bindir=/bin"
econf ${myconf} || die
diff --git a/sys-apps/attr/attr-2.4.19.ebuild b/sys-apps/attr/attr-2.4.19.ebuild
new file mode 100644
index 000000000000..f7a6f52b9640
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.19.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.19.ebuild,v 1.1 2004/10/10 00:43:28 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls debug"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ virtual/libc
+ nls? ( sys-devel/gettext )
+ sys-devel/libtool"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^PKG_[[:upper:]]*_DIR/s:= := $(DESTDIR):' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+
+ # More extensive man 2 documentation is found in the man-pages package,
+ # so disable the installation of them
+ epatch ${FILESDIR}/${PN}-no-man2pages.patch
+}
+
+src_compile() {
+ if use debug; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ # Some archs need the PLATFORM var unset
+ if hasq ${ARCH} mips ppc sparc ppc64 s390; then
+ unset PLATFORM
+ fi
+
+ econf \
+ $(use_enable nls gettext) \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-lib install-dev || die
+}
diff --git a/sys-apps/attr/files/digest-attr-2.4.19 b/sys-apps/attr/files/digest-attr-2.4.19
new file mode 100644
index 000000000000..88e7315bc676
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-2.4.19
@@ -0,0 +1 @@
+MD5 f08b2602e455a28578b24fd7d0afe292 attr-2.4.19.src.tar.gz 103596