summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-01-10 12:06:18 +0000
committerFabian Groffen <grobian@gentoo.org>2013-01-10 12:06:18 +0000
commitd675b8eec1966b1535e5f7059fa18c8877ba23b7 (patch)
treee5635aa406d3e9ef52abe64222256b925ad34143 /sys-apps/baselayout-prefix
parentEnable optional support for libspectre via USE-flag, fix bug #451088. Thanks ... (diff)
downloadgentoo-2-d675b8eec1966b1535e5f7059fa18c8877ba23b7.tar.gz
gentoo-2-d675b8eec1966b1535e5f7059fa18c8877ba23b7.tar.bz2
gentoo-2-d675b8eec1966b1535e5f7059fa18c8877ba23b7.zip
Version bump. Takes libeinfo and einfo from forked OpenRC, takes profile from baselayout-2.2.
(Portage version: 2.2.01.21476-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-apps/baselayout-prefix')
-rw-r--r--sys-apps/baselayout-prefix/ChangeLog12
-rw-r--r--sys-apps/baselayout-prefix/baselayout-prefix-2.2.ebuild80
2 files changed, 89 insertions, 3 deletions
diff --git a/sys-apps/baselayout-prefix/ChangeLog b/sys-apps/baselayout-prefix/ChangeLog
index 94bbbbee3733..a7b28b84e648 100644
--- a/sys-apps/baselayout-prefix/ChangeLog
+++ b/sys-apps/baselayout-prefix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/baselayout-prefix
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/ChangeLog,v 1.20 2012/08/11 10:19:18 heroxbd Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/ChangeLog,v 1.21 2013/01/10 12:06:18 grobian Exp $
+
+*baselayout-prefix-2.2 (10 Jan 2013)
+
+ 10 Jan 2013; Fabian Groffen <grobian@gentoo.org>
+ +baselayout-prefix-2.2.ebuild:
+ Version bump. Takes libeinfo and einfo from forked OpenRC, takes profile from
+ baselayout-2.2.
11 Aug 2012; Benda Xu <heroxbd@gentoo.org>
baselayout-prefix-1.12.14-r1.ebuild:
@@ -211,4 +218,3 @@
12 May 2005; Joseph Jezak <josejx@gentoo.org> +metadata.xml,
+baselayout-darwin-1.11.11.ebuild:
Initial commit.
-
diff --git a/sys-apps/baselayout-prefix/baselayout-prefix-2.2.ebuild b/sys-apps/baselayout-prefix/baselayout-prefix-2.2.ebuild
new file mode 100644
index 000000000000..70d185bddc1c
--- /dev/null
+++ b/sys-apps/baselayout-prefix/baselayout-prefix-2.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/baselayout-prefix-2.2.ebuild,v 1.1 2013/01/10 12:06:18 grobian Exp $
+
+EAPI=3
+
+inherit eutils multilib
+
+MY_P=${P/-prefix/} # just use "upstream" sources
+EINFO=einfo-1.0
+DESCRIPTION="Minimal baselayout and e-functions for Gentoo Prefix installs"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~grobian/distfiles/${EINFO}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="build kernel_linux"
+
+S=${WORKDIR}/${EINFO}
+
+pkg_preinst() {
+ # This is written in src_install (so it's in CONTENTS), but punt all
+ # pending updates to avoid user having to do etc-update (and make the
+ # pkg_postinst logic simpler).
+ rm -f "${EROOT}"/etc/._cfg????_gentoo-release
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}/usr/lib/einfo"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # make functions.sh available in /etc/init.d
+ # Note: we cannot replace the symlink with a file here, or Portage will
+ # config-protect it, and etc-update can't handle symlink to file updates
+ dodir etc/init.d
+ dosym ../../usr/lib/einfo/sh/functions.sh /etc/init.d/functions.sh
+
+ pushd "${WORKDIR}"/${MY_P} > /dev/null || die
+ dodir etc
+ sed \
+ -e "/PATH=/!s:/\(etc\|usr/bin\|bin\):\"${EPREFIX}\"/\1:g" \
+ -e "/PATH=/s|\([:\"]\)/|\1${EPREFIX}/|g" \
+ -e "/PATH=.*\/sbin/s|\"$|:/usr/sbin:/sbin\"|" \
+ -e "/PATH=.*\/bin/s|\"$|:/usr/bin:/bin\"|" \
+ etc/profile > "${ED}"/etc/profile || die
+ dodir etc/env.d
+ sed \
+ -e "s:/\(etc/env.d\|opt\|usr\):${EPREFIX}/\1:g" \
+ -e "/^PATH=/s|\"$|:${EPREFIX}/usr/sbin:${EPREFIX}/sbin\"|" \
+ etc/env.d/00basic > "${ED}"/etc/env.d/00basic || die
+ dodoc ChangeLog.svn
+ popd > /dev/null
+
+ # add the host OS MANPATH
+ [[ -d "${ROOT}"/usr/share/man ]] && \
+ echo 'MANPATH="/usr/share/man"' > "${ED}"/etc/env.d/99basic || die
+
+ # rc-scripts version for testing of features that *should* be present
+ echo "Gentoo Prefix Base System release ${PV}" > "${ED}"/etc/gentoo-release
+
+ # FHS compatibility symlinks stuff
+ dosym /var/tmp /usr/tmp
+}
+
+pkg_postinst() {
+ # Take care of the etc-update for the user
+ if [ -e "${EROOT}"/etc/._cfg0000_gentoo-release ] ; then
+ mv "${EROOT}"/etc/._cfg0000_gentoo-release "${EROOT}"/etc/gentoo-release
+ fi
+
+ # baselayout leaves behind a lot of .keep files, so let's clean them up
+ find "${EROOT}"/lib/rcscripts/ -name .keep -exec rm -f {} + 2>/dev/null
+ find "${EROOT}"/lib/rcscripts/ -depth -type d -exec rmdir {} + 2>/dev/null
+}