summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-04 23:26:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-04 23:26:08 +0000
commit0997439f327d2178fb12d7e7a802c74c80bd8169 (patch)
tree80e0ad95e008f75fc4aaf48e259e2012fc90f672 /sys-apps/busybox
parentbug 95048 (diff)
downloadgentoo-2-0997439f327d2178fb12d7e7a802c74c80bd8169.tar.gz
gentoo-2-0997439f327d2178fb12d7e7a802c74c80bd8169.tar.bz2
gentoo-2-0997439f327d2178fb12d7e7a802c74c80bd8169.zip
gcc4 patch #95002
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.00-r4.ebuild3
-rw-r--r--sys-apps/busybox/files/1.00/gcc4.patch25
2 files changed, 27 insertions, 1 deletions
diff --git a/sys-apps/busybox/busybox-1.00-r4.ebuild b/sys-apps/busybox/busybox-1.00-r4.ebuild
index d192108c291e..46b77cdf1aa1 100644
--- a/sys-apps/busybox/busybox-1.00-r4.ebuild
+++ b/sys-apps/busybox/busybox-1.00-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r4.ebuild,v 1.9 2005/06/04 03:39:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r4.ebuild,v 1.10 2005/06/04 23:26:08 vapier Exp $
inherit eutils
@@ -59,6 +59,7 @@ src_unpack() {
epatch "${FILESDIR}"/1.00/sum.patch
epatch "${FILESDIR}"/1.00/bb.patch
epatch "${WORKDIR}"/${P}-e2fsprogs.patch
+ epatch "${FILESDIR}"/1.00/gcc4.patch
# Don't let KBUILD_OUTPUT mess us up #88088
unset KBUILD_OUTPUT
diff --git a/sys-apps/busybox/files/1.00/gcc4.patch b/sys-apps/busybox/files/1.00/gcc4.patch
new file mode 100644
index 000000000000..bd11c00ff653
--- /dev/null
+++ b/sys-apps/busybox/files/1.00/gcc4.patch
@@ -0,0 +1,25 @@
+gcc 4 fixes from upstream
+
+--- busybox-1.00/archival/gzip.c
++++ busybox-1.00/archival/gzip.c
+@@ -2162,7 +2162,7 @@
+ * Construct the Huffman tree for the bit lengths and return the index in
+ * bl_order of the last bit length code to send.
+ */
+-static const int build_bl_tree()
++static int build_bl_tree()
+ {
+ int max_blindex; /* index of last bit length code of non zero freq */
+
+--- busybox-1.00/networking/ifupdown.c
++++ busybox-1.00/networking/ifupdown.c
+@@ -150,7 +150,9 @@
+
+ static char no_act = 0;
+ static char verbose = 0;
++#ifndef __USE_GNU
+ static char **environ = NULL;
++#endif
+
+ #ifdef CONFIG_FEATURE_IFUPDOWN_IP
+