summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-08 02:30:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-08 02:30:29 +0000
commit67372a398683a899fdb6a99e640263ea993e25f4 (patch)
tree4ddc6859ab68456a1d7305ecd0f511fa313d8957 /sys-apps/collectl
parentAdd prefix keywords, patch for Interix (diff)
downloadgentoo-2-67372a398683a899fdb6a99e640263ea993e25f4.tar.gz
gentoo-2-67372a398683a899fdb6a99e640263ea993e25f4.tar.bz2
gentoo-2-67372a398683a899fdb6a99e640263ea993e25f4.zip
Version bump #292864 by Mark Seger.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/collectl')
-rw-r--r--sys-apps/collectl/ChangeLog10
-rw-r--r--sys-apps/collectl/collectl-3.4.0.ebuild41
-rw-r--r--sys-apps/collectl/files/collectl-3.4.0-install.patch55
3 files changed, 104 insertions, 2 deletions
diff --git a/sys-apps/collectl/ChangeLog b/sys-apps/collectl/ChangeLog
index fc5d90327702..d6515be8d19b 100644
--- a/sys-apps/collectl/ChangeLog
+++ b/sys-apps/collectl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/collectl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/ChangeLog,v 1.7 2009/11/15 01:29:22 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/ChangeLog,v 1.8 2010/01/08 02:30:29 vapier Exp $
+
+*collectl-3.4.0 (08 Jan 2010)
+
+ 08 Jan 2010; Mike Frysinger <vapier@gentoo.org> +collectl-3.4.0.ebuild,
+ +files/collectl-3.4.0-install.patch:
+ Version bump #292864 by Mark Seger.
15 Nov 2009; Mike Frysinger <vapier@gentoo.org> files/collectl.initd:
Fix path to collectl #292864 by DBautell.
diff --git a/sys-apps/collectl/collectl-3.4.0.ebuild b/sys-apps/collectl/collectl-3.4.0.ebuild
new file mode 100644
index 000000000000..70c62fd27256
--- /dev/null
+++ b/sys-apps/collectl/collectl-3.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/collectl-3.4.0.ebuild,v 1.1 2010/01/08 02:30:29 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="light-weight performance monitoring tool capable of reporting interactively as well as logging to disk"
+HOMEPAGE="http://collectl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/collectl/${P}.src.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.8
+ virtual/perl-Time-HiRes
+ >=dev-perl/Archive-Zip-1.20
+ sys-apps/ethtool
+ sys-apps/pciutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-install.patch
+ sed -i \
+ -e "/^DOCDIR/s:doc/collectl:doc/${PF}:" \
+ INSTALL || die
+}
+
+src_install() {
+ DESTDIR=${D} bash -ex ./INSTALL || die
+
+ rm "${D}"/etc/init.d/* || die
+ newinitd "${FILESDIR}"/collectl.initd collectl
+
+ cd "${D}"/usr/share/doc/${PF}
+ dohtml * || die
+ rm -f ARTISTIC GPL COPYING *.html *.jpg *.css || die
+ prepalldocs
+}
diff --git a/sys-apps/collectl/files/collectl-3.4.0-install.patch b/sys-apps/collectl/files/collectl-3.4.0-install.patch
new file mode 100644
index 000000000000..647059c01553
--- /dev/null
+++ b/sys-apps/collectl/files/collectl-3.4.0-install.patch
@@ -0,0 +1,55 @@
+add DESTDIR support
+
+--- INSTALL
++++ INSTALL
+@@ -1,18 +1,22 @@
+ #!/bin/bash
+
+-BINDIR=/usr/bin
+-DOCDIR=/usr/share/doc/collectl
+-SHRDIR=/usr/share/collectl
++#DESTDIR=
++BINDIR=$DESTDIR/usr/bin
++DOCDIR=$DESTDIR/usr/share/doc/collectl
++SHRDIR=$DESTDIR/usr/share/collectl
+
++mkdir -p $BINDIR
+ mkdir -p $DOCDIR
+ mkdir -p $SHRDIR
+ mkdir -p $SHRDIR/util
+-mkdir -p /var/log/collectl
++mkdir -p $DESTDIR/etc/init.d
++mkdir -p $DESTDIR/usr/share/man/man1
++mkdir -p $DESTDIR/var/log/collectl
+
+ cp collectl.pl $BINDIR/collectl
+-cp collectl.conf /etc
+-cp initd/* /etc/init.d
+-cp man1/* /usr/share/man/man1
++cp collectl.conf $DESTDIR/etc
++cp initd/* $DESTDIR/etc/init.d
++cp man1/* $DESTDIR/usr/share/man/man1
+
+ cp docs/* $DOCDIR
+ cp GPL ARTISTIC COPYING $DOCDIR
+@@ -28,15 +32,17 @@
+ cp col2tlviz.pl $SHRDIR/util
+
+ # Force in case redoing the install and files already zipped
+-gzip -f /usr/share/man/man1/collectl*
++gzip -f $DESTDIR/usr/share/man/man1/collectl*
+
+-chmod 755 /etc/init.d/collectl*
+-chmod 444 /etc/collectl.conf
++chmod 755 $DESTDIR/etc/init.d/collectl*
++chmod 444 $DESTDIR/etc/collectl.conf
+ chmod 755 $BINDIR/collectl
+ chmod 444 $DOCDIR/ARTISTIC $DOCDIR/COPYING $DOCDIR/GPL
+ chmod 755 $SHRDIR/util/*
+ chmod 444 $SHRDIR/formatit.ph $SHRDIR/*expr.ph $SHRDIR/vmstat.ph
+
++[[ -n $DESTDIR ]] && exit 0
++
+ # remove any stale versions in case the names/numbers used have changed.
+ # on new ROCKS installion 'rm' isn't there yet! [thanks roy]
+ if [ -x /bin/rm ] ; then