summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-07-20 17:11:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-07-20 17:11:07 +0000
commitaa3edaff192630824e6f0e499a977c00d0128616 (patch)
treeb5bceb06948cd7a5913e72e14cb94107995a9954 /sys-apps/cpuid
parentupdate numpy in RDEPEND, fixes Bug #471850 (diff)
downloadgentoo-2-aa3edaff192630824e6f0e499a977c00d0128616.tar.gz
gentoo-2-aa3edaff192630824e6f0e499a977c00d0128616.tar.bz2
gentoo-2-aa3edaff192630824e6f0e499a977c00d0128616.zip
Version bump
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/ChangeLog9
-rw-r--r--sys-apps/cpuid/cpuid-20130610.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/sys-apps/cpuid/ChangeLog b/sys-apps/cpuid/ChangeLog
index a4158b2c9233..b9f294076848 100644
--- a/sys-apps/cpuid/ChangeLog
+++ b/sys-apps/cpuid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/cpuid
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/ChangeLog,v 1.5 2012/07/19 21:45:46 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/ChangeLog,v 1.6 2013/07/20 17:11:07 hwoarang Exp $
+
+*cpuid-20130610 (20 Jul 2013)
+
+ 20 Jul 2013; Markos Chandras <hwoarang@gentoo.org> +cpuid-20130610.ebuild:
+ Version bump
*cpuid-20120601 (19 Jul 2012)
diff --git a/sys-apps/cpuid/cpuid-20130610.ebuild b/sys-apps/cpuid/cpuid-20130610.ebuild
new file mode 100644
index 000000000000..77f94d7cd305
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20130610.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/cpuid-20130610.ebuild,v 1.1 2013/07/20 17:11:07 hwoarang Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20110305-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}