summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-21 16:13:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-21 16:13:51 +0000
commit2cdfcd97d6d578d2d21877edfc95e7b11d12c17c (patch)
tree7c992fa4be4e235477ddb8ee263a0336d1fd2d7f /sys-apps/dbus
parentstop creating linker scripts for non darwin/linux systems #417451 (diff)
downloadgentoo-2-2cdfcd97d6d578d2d21877edfc95e7b11d12c17c.tar.gz
gentoo-2-2cdfcd97d6d578d2d21877edfc95e7b11d12c17c.tar.bz2
gentoo-2-2cdfcd97d6d578d2d21877edfc95e7b11d12c17c.zip
amd64/ppc/ppc64 stable wrt #416725 with systemd workaround, see the ebuild for has_version
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog9
-rw-r--r--sys-apps/dbus/dbus-1.6.2.ebuild16
2 files changed, 17 insertions, 8 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index ae2e92eeacc3..d0a24995957e 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/dbus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.347 2012/07/20 23:07:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.348 2012/07/21 16:13:51 ssuominen Exp $
+
+ 21 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> dbus-1.6.2.ebuild:
+ amd64/ppc/ppc64 stable wrt #416725
+
+ 21 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> dbus-1.6.2.ebuild:
+ Use has_version instead of dependency for sys-apps/systemd regarding
+ stabilization. This is only for 1.6.2 and will be left as-is for 1.6.4.
*dbus-1.6.4 (20 Jul 2012)
diff --git a/sys-apps/dbus/dbus-1.6.2.ebuild b/sys-apps/dbus/dbus-1.6.2.ebuild
index 729fd530523b..8dfcea34864a 100644
--- a/sys-apps/dbus/dbus-1.6.2.ebuild
+++ b/sys-apps/dbus/dbus-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.2.ebuild,v 1.2 2012/07/20 15:06:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.2.ebuild,v 1.3 2012/07/21 16:13:51 ssuominen Exp $
EAPI=4
inherit autotools eutils linux-info flag-o-matic python systemd virtualx user
@@ -11,7 +11,7 @@ SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
LICENSE="|| ( AFL-2.1 GPL-2 )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="debug doc selinux static-libs systemd test X"
RDEPEND=">=dev-libs/expat-2
@@ -19,7 +19,6 @@ RDEPEND=">=dev-libs/expat-2
sec-policy/selinux-dbus
sys-libs/libselinux
)
- systemd? ( >=sys-apps/systemd-32 )
X? (
x11-libs/libX11
x11-libs/libXt
@@ -71,14 +70,18 @@ src_prepare() {
}
src_configure() {
- local myconf
-
# so we can get backtraces from apps
append-flags -rdynamic
+ # temp. hack for stable wrt #416725#c5
+ local myconf=( --disable-systemd )
+ if use systemd && has_version sys-apps/systemd; then
+ myconf=( --enable-systemd )
+ fi
+
# libaudit is *only* used in DBus wrt SELinux support, so disable it, if
# not on an SELinux profile.
- myconf=(
+ myconf+=(
--localstatedir=/var
--docdir=/usr/share/doc/${PF}
--htmldir=/usr/share/doc/${PF}/html
@@ -90,7 +93,6 @@ src_configure() {
$(use_enable selinux libaudit)
$(use_enable kernel_linux inotify)
$(use_enable kernel_FreeBSD kqueue)
- $(use_enable systemd)
--disable-embedded-tests
--disable-modular-tests
$(use_enable debug stats)