summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 20:09:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 20:09:47 +0000
commit1806d070a74735948863897e4beb0793fcebaf87 (patch)
treed985cebbf7fa62d96b1a21aa092fe4eecb4f642f /sys-apps/discover/discover-2.0.2.ebuild
parentbug #26728, security bump, held up for a long time by DB4.1 (Manifest recommit) (diff)
downloadgentoo-2-1806d070a74735948863897e4beb0793fcebaf87.tar.gz
gentoo-2-1806d070a74735948863897e4beb0793fcebaf87.tar.bz2
gentoo-2-1806d070a74735948863897e4beb0793fcebaf87.zip
ver bump #40345
Diffstat (limited to 'sys-apps/discover/discover-2.0.2.ebuild')
-rw-r--r--sys-apps/discover/discover-2.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/discover/discover-2.0.2.ebuild b/sys-apps/discover/discover-2.0.2.ebuild
new file mode 100644
index 000000000000..0cb8253102a5
--- /dev/null
+++ b/sys-apps/discover/discover-2.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover/discover-2.0.2.ebuild,v 1.1 2004/02/08 20:09:47 vapier Exp $
+
+DESCRIPTION="Library and front-end for retrieving information about a system's hardware"
+HOMEPAGE="http://hackers.progeny.com/discover/"
+SRC_URI="http://archive.progeny.com/progeny/discover/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="pcmcia"
+
+DEPEND="pcmcia? ( virtual/linux-sources )
+ net-ftp/curl
+ dev-libs/expat"
+PDEPEND="sys-apps/discover-data"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ which docbook-to-man 2>/dev/null \
+ || sed -i 's:docbook-to-man:docbook2man:' doctools/docbook.mk
+}
+
+src_compile() {
+ local myconf=""
+ use pcmcia \
+ && myconf="--with-pcmcia-headers=/usr/src/linux/include"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS README RELEASE
+}