summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-11-25 13:43:10 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-11-25 13:43:10 +0000
commita4597f90c1ad91950b42d7bf84a7201553619479 (patch)
tree736219f3576f2f943c921b5a70e2e1a97c40c908 /sys-apps/dstat
parentRemove 2 masked old vers. (diff)
downloadgentoo-2-a4597f90c1ad91950b42d7bf84a7201553619479.tar.gz
gentoo-2-a4597f90c1ad91950b42d7bf84a7201553619479.tar.bz2
gentoo-2-a4597f90c1ad91950b42d7bf84a7201553619479.zip
Fix Untrusted Search Path Vulnerability (CVE-2009-3894), bug 293497.
(Portage version: 2.1.7.1/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-apps/dstat')
-rw-r--r--sys-apps/dstat/ChangeLog8
-rw-r--r--sys-apps/dstat/dstat-0.6.9-r1.ebuild39
-rw-r--r--sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch15
3 files changed, 61 insertions, 1 deletions
diff --git a/sys-apps/dstat/ChangeLog b/sys-apps/dstat/ChangeLog
index d4407467c978..0f41ecb22785 100644
--- a/sys-apps/dstat/ChangeLog
+++ b/sys-apps/dstat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dstat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.31 2009/06/28 14:06:58 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.32 2009/11/25 13:43:09 rbu Exp $
+
+*dstat-0.6.9-r1 (25 Nov 2009)
+
+ 25 Nov 2009; Robert Buchholz <rbu@gentoo.org> +dstat-0.6.9-r1.ebuild,
+ +files/dstat-0.6.9-CVE-2009-3894.patch:
+ Fix Untrusted Search Path Vulnerability (CVE-2009-3894), bug 293497.
28 Jun 2009; Tobias Klausmann <klausman@gentoo.org> dstat-0.6.9.ebuild:
Keyworded on alpha, bug #274851
diff --git a/sys-apps/dstat/dstat-0.6.9-r1.ebuild b/sys-apps/dstat/dstat-0.6.9-r1.ebuild
new file mode 100644
index 000000000000..ceb97e2be1a4
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.6.9-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.6.9-r1.ebuild,v 1.1 2009/11/25 13:43:09 rbu Exp $
+
+EAPI=2
+inherit python eutils
+
+DESCRIPTION="Dstat is a versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ~ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="virtual/python"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2009-3894.patch # 293497
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc \
+ AUTHORS ChangeLog README TODO \
+ examples/{mstat,read}.py docs/*.txt \
+ || die "dodoc failed"
+ dohtml docs/*.html || die "dohtml failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}
diff --git a/sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch b/sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch
new file mode 100644
index 000000000000..042552b9a3bd
--- /dev/null
+++ b/sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=293497
+
+Index: dstat-0.6.9/dstat
+===================================================================
+--- dstat-0.6.9.orig/dstat
++++ dstat-0.6.9/dstat
+@@ -28,8 +28,6 @@ try:
+ inspath('/usr/local/share/dstat/')
+ inspath('/usr/share/dstat/')
+ inspath(os.path.abspath(os.path.dirname(sys.argv[0])) + '/plugins/') # binary path + /plugins/
+- inspath(os.getcwd() + '/plugins/') # current path + /plugins/
+- inspath(os.getcwd()) # current path
+ inspath(os.path.expanduser('~/.dstat/')) # home + /.dstat/
+ except KeyboardInterrupt, e:
+ pass