summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-03-03 21:37:44 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-03-03 21:37:44 +0000
commitbeea9eef41c40b60047469d538c2b76824a4689f (patch)
treec4fb845a5df45cd54e8c2853775bcc724d0d9ee5 /sys-apps/einit
parentadd USE=relaxng for sys-apps/einit (diff)
downloadgentoo-2-beea9eef41c40b60047469d538c2b76824a4689f.tar.gz
gentoo-2-beea9eef41c40b60047469d538c2b76824a4689f.tar.bz2
gentoo-2-beea9eef41c40b60047469d538c2b76824a4689f.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps/einit')
-rw-r--r--sys-apps/einit/ChangeLog7
-rw-r--r--sys-apps/einit/einit-0.40.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/einit/ChangeLog b/sys-apps/einit/ChangeLog
index fac60831c890..f19589540273 100644
--- a/sys-apps/einit/ChangeLog
+++ b/sys-apps/einit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/einit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/einit/ChangeLog,v 1.7 2008/03/03 21:06:04 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/einit/ChangeLog,v 1.8 2008/03/03 21:37:44 opfer Exp $
+
+*einit-0.40.0 (03 Mar 2008)
+
+ 03 Mar 2008; Christian Faulhammer <opfer@gentoo.org> +einit-0.40.0.ebuild:
+ version bump
03 Mar 2008; Christian Faulhammer <opfer@gentoo.org> metadata.xml:
add myself as maintainer
diff --git a/sys-apps/einit/einit-0.40.0.ebuild b/sys-apps/einit/einit-0.40.0.ebuild
new file mode 100644
index 000000000000..dfe30a234e17
--- /dev/null
+++ b/sys-apps/einit/einit-0.40.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/einit/einit-0.40.0.ebuild,v 1.1 2008/03/03 21:37:44 opfer Exp $
+
+EAPI="1"
+
+inherit eutils python
+
+DESCRIPTION="An alternate /sbin/init implementation"
+SRC_URI="http://einit.org/files/${P}.tar.bz2"
+HOMEPAGE="http://einit.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="debug doc +relaxng"
+
+DEPEND="doc? ( app-text/docbook-sgml app-doc/doxygen )
+ dev-util/scons"
+PDEPEND=">=sys-apps/einit-modules-xml-2.0.0.0
+ >=sys-apps/einit-modules-scheme-1.0.0.0
+ relaxng? ( app-text/rnv )"
+
+pkg_setup() {
+ enewgroup einit || die
+ if [ $(getconf GNU_LIBPTHREAD_VERSION | cut -d " " -f 1) != "NPTL" ]; then
+ break;
+ fi
+}
+
+src_unpack() {
+ unpack ${A} || die
+ python_version || die
+}
+
+src_compile() {
+
+ scons ${MAKEOPTS:--j2} libdir="$(get_libdir)" destdir="${D}/${ROOT}/" prefix="${ROOT}" || die
+}
+
+src_install() {
+ scons libdir="$(get_libdir)" destdir="${D}/${ROOT}/" prefix="${ROOT}" install || die
+
+ mkdir -p "${D}/${ROOT}/bin"
+ ln -s ../sbin/einit "${D}/${ROOT}/bin/einit"
+ ln -s ../"$(get_libdir)"/einit/bin/einit-log "${D}/${ROOT}/bin/einit-log"
+ ln -s ../$(get_libdir)/einit/bin/einit-feedback "${D}/${ROOT}/bin/einit-feedback"
+
+ doman documentation/man/*.8
+}
+
+pkg_postinst() {
+ elog "eINIT is now installed, but you will still need to configure it."
+ elog
+ elog "To use einit as a non-root user, add that user to the group 'einit'."
+ elog
+ elog "You can always find the latest documentation at"
+ elog "http://einit.org/"
+ elog
+}