summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-13 05:12:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-13 05:12:21 +0000
commit958e8944a244b29e5d6ae71930e7ee1982d99669 (patch)
tree5f60a8f3027b7bfee84481da6e05808f73b058d7 /sys-apps/eject/files
parentStable on sparc. (diff)
downloadgentoo-2-958e8944a244b29e5d6ae71930e7ee1982d99669.tar.gz
gentoo-2-958e8944a244b29e5d6ae71930e7ee1982d99669.tar.bz2
gentoo-2-958e8944a244b29e5d6ae71930e7ee1982d99669.zip
Grab a bunch of patches from Fedora.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps/eject/files')
-rw-r--r--sys-apps/eject/files/digest-eject-2.0.13-r11
-rw-r--r--sys-apps/eject/files/eject-2.0.13-autoclose.patch28
-rw-r--r--sys-apps/eject/files/eject-2.0.13-finddev.patch16
-rw-r--r--sys-apps/eject/files/eject-2.0.13-header.patch24
-rw-r--r--sys-apps/eject/files/eject-2.0.13-kernel25-support.patch6
-rw-r--r--sys-apps/eject/files/eject-2.0.13-use-mountpoints.patch33
6 files changed, 106 insertions, 2 deletions
diff --git a/sys-apps/eject/files/digest-eject-2.0.13-r1 b/sys-apps/eject/files/digest-eject-2.0.13-r1
new file mode 100644
index 000000000000..3c64dc062a37
--- /dev/null
+++ b/sys-apps/eject/files/digest-eject-2.0.13-r1
@@ -0,0 +1 @@
+MD5 b796ad77beb4e7bdd08d6149701ab778 eject-2.0.13.tar.gz 59504
diff --git a/sys-apps/eject/files/eject-2.0.13-autoclose.patch b/sys-apps/eject/files/eject-2.0.13-autoclose.patch
new file mode 100644
index 000000000000..9d3662b19c05
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.13-autoclose.patch
@@ -0,0 +1,28 @@
+Ripped from Fedora
+
+--- eject.c Tue Jul 3 00:17:41 2001
++++ eject.c Tue Feb 5 05:50:58 2002
+@@ -361,8 +361,11 @@
+ {
+ int status;
+
+- status = ioctl(fd, CDROMEJECT_SW, onOff);
+- if (status != 0) {
++ if (onOff)
++ status = ioctl(fd, CDROM_SET_OPTIONS, CDO_AUTO_EJECT);
++ else
++ status = ioctl(fd, CDROM_CLEAR_OPTIONS, CDO_AUTO_EJECT);
++ if (status < 0) {
+ fprintf(stderr, _("%s: CD-ROM auto-eject command failed: %s\n"), programName, strerror(errno));
+ exit(1);
+ }
+--- volname.c Tue Jul 3 00:17:41 2001
++++ volname.c Tue Feb 5 05:29:49 2002
+@@ -35,6 +35,7 @@
+
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/sys-apps/eject/files/eject-2.0.13-finddev.patch b/sys-apps/eject/files/eject-2.0.13-finddev.patch
new file mode 100644
index 000000000000..8b12504907fa
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.13-finddev.patch
@@ -0,0 +1,16 @@
+Ripped from Fedora
+
+--- eject-2.0.13/eject.c.orig 2004-09-07 12:10:58.382649630 +0200
++++ eject-2.0.13/eject.c 2004-09-07 12:10:43.930067903 +0200
+@@ -326,6 +326,11 @@
+ if (FileExists(buf))
+ return buf;
+
++ strcpy(buf, "/media/");
++ strcat(buf, name);
++ if (FileExists(buf))
++ return buf;
++
+ /* for devfs under Linux */
+ strcpy(buf, "/dev/cdroms/");
+ strcat(buf, name);
diff --git a/sys-apps/eject/files/eject-2.0.13-header.patch b/sys-apps/eject/files/eject-2.0.13-header.patch
new file mode 100644
index 000000000000..044f9712798f
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.13-header.patch
@@ -0,0 +1,24 @@
+Ripped from Fedora
+
+--- eject-2.0.13/Makefile.am.orig 2004-02-25 17:18:28.000000000 +0100
++++ eject-2.0.13/Makefile.am 2004-02-25 17:18:42.000000000 +0100
+@@ -4,7 +4,7 @@
+
+ SUBDIRS = po
+
+-AM_CPPFLAGS = -I/usr/src/linux -I/usr/src/linux/include -DDEFAULTDEVICE=\"$(DEFAULTDEVICE)\" -DGETOPTLONG
++AM_CPPFLAGS = -DDEFAULTDEVICE=\"$(DEFAULTDEVICE)\" -DGETOPTLONG
+ AM_CFLAGS = -Wall -O3 $(RPM_OPT_FLAGS)
+
+ man_MANS = eject.1 volname.1
+--- eject-2.0.13/Makefile.in.orig 2004-02-25 17:18:57.000000000 +0100
++++ eject-2.0.13/Makefile.in 2004-02-25 17:19:28.000000000 +0100
+@@ -69,7 +69,7 @@
+
+ SUBDIRS = po
+
+-AM_CPPFLAGS = -I/usr/src/linux -I/usr/src/linux/include -DDEFAULTDEVICE=\"$(DEFAULTDEVICE)\" -DGETOPTLONG
++AM_CPPFLAGS = -DDEFAULTDEVICE=\"$(DEFAULTDEVICE)\" -DGETOPTLONG
+ AM_CFLAGS = -Wall -O3 $(RPM_OPT_FLAGS)
+
+ man_MANS = eject.1 volname.1
diff --git a/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch b/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch
index 7cafe9e51759..a42f3f791c9e 100644
--- a/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch
+++ b/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch
@@ -1,5 +1,7 @@
---- eject.c.orig 2002-12-09 22:28:08.000000000 +0000
-+++ eject.c 2003-11-08 17:06:43.000000000 +0000
+ # Get this puppy working with kernel 2.5.x
+ # <azarah@gentoo.org> (06 March 2003)
+--- eject.c.orig
++++ eject.c
@@ -58,7 +58,13 @@
#include <sys/ioctl.h>
#include <sys/wait.h>
diff --git a/sys-apps/eject/files/eject-2.0.13-use-mountpoints.patch b/sys-apps/eject/files/eject-2.0.13-use-mountpoints.patch
new file mode 100644
index 000000000000..9b12992a7c28
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.13-use-mountpoints.patch
@@ -0,0 +1,33 @@
+Ripped from Fedora
+
+More recent kernels actually want to umount using the mount point and
+not the device name (this makes more sense, you can have the same
+device mounted in many places).
+
+This is a minor changes to do just that.
+
+diff --exclude=debian -Nur eject-2.0.13deb/eject.c eject-2.0.13deb.cw/eject.c
+--- eject-2.0.13deb/eject.c 2004-04-17 12:25:10.000000000 -0700
++++ eject-2.0.13deb.cw/eject.c 2004-04-17 12:26:55.000000000 -0700
+@@ -718,8 +718,8 @@
+ status = regexec(&preg, s1, 0, 0, 0);
+ if (status == 0) {
+ if (v_option)
+- printf(_("%s: unmounting `%s'\n"), programName, s1);
+- Unmount(s1);
++ printf(_("%s: unmounting `%s'\n"), programName, s2);
++ Unmount(s2);
+ regfree(&preg);
+ }
+ }
+@@ -952,8 +952,8 @@
+ /* unmount device if mounted */
+ if (mounted) {
+ if (v_option)
+- printf(_("%s: unmounting `%s'\n"), programName, deviceName);
+- Unmount(deviceName);
++ printf(_("%s: unmounting device `%s' from `%s'\n"), programName, deviceName, mountName);
++ Unmount(mountName);
+ }
+
+ /* if it is a multipartition device, unmount any other partitions on