summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-09-04 21:31:29 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-09-04 21:31:29 +0000
commit7e0072fba0460df2522977372cb2403b3fd0eb99 (patch)
tree3679701e4281f2e613561ac4e8ffeed6d9f36e52 /sys-apps/fcron
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-7e0072fba0460df2522977372cb2403b3fd0eb99.tar.gz
gentoo-2-7e0072fba0460df2522977372cb2403b3fd0eb99.tar.bz2
gentoo-2-7e0072fba0460df2522977372cb2403b3fd0eb99.zip
GCC 3.4 fix by Mark Loeser, closes bug #62625
Diffstat (limited to 'sys-apps/fcron')
-rw-r--r--sys-apps/fcron/ChangeLog6
-rw-r--r--sys-apps/fcron/fcron-2.0.0-r4.ebuild3
-rw-r--r--sys-apps/fcron/files/fcron-2.0.0-gcc34.diff10
3 files changed, 17 insertions, 2 deletions
diff --git a/sys-apps/fcron/ChangeLog b/sys-apps/fcron/ChangeLog
index 96de4d3a52fb..517b51d1d747 100644
--- a/sys-apps/fcron/ChangeLog
+++ b/sys-apps/fcron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/fcron
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/ChangeLog,v 1.28 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/ChangeLog,v 1.29 2004/09/04 21:31:29 chainsaw Exp $
+
+ 04 Sep 2004; Tony Vroon <chainsaw@gentoo.org> +files/fcron-2.0.0-gcc34.diff,
+ fcron-2.0.0-r4.ebuild:
+ GCC 3.4 compile fix; patch by Mark Loeser. Closes bug #62625.
03 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> fcron-2.9.4.ebuild:
Masked fcron-2.9.4.ebuild stable for ppc
diff --git a/sys-apps/fcron/fcron-2.0.0-r4.ebuild b/sys-apps/fcron/fcron-2.0.0-r4.ebuild
index 8baed5402356..0c32b23238e0 100644
--- a/sys-apps/fcron/fcron-2.0.0-r4.ebuild
+++ b/sys-apps/fcron/fcron-2.0.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.0.0-r4.ebuild,v 1.6 2004/06/24 22:05:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.0.0-r4.ebuild,v 1.7 2004/09/04 21:31:29 chainsaw Exp $
inherit eutils
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc34.diff
# fix LIBOBJS vs AC_LIBOBJ problem
sed -i -e 's|LIBOBJS|AC_LIBOBJ|g' configure.in
autoconf || die "autoconf problem"
diff --git a/sys-apps/fcron/files/fcron-2.0.0-gcc34.diff b/sys-apps/fcron/files/fcron-2.0.0-gcc34.diff
new file mode 100644
index 000000000000..1dc1a27a622d
--- /dev/null
+++ b/sys-apps/fcron/files/fcron-2.0.0-gcc34.diff
@@ -0,0 +1,10 @@
+diff -ur fcron-2.0.0-orig/conf.c fcron-2.0.0/conf.c
+--- fcron-2.0.0-orig/conf.c 2004-09-04 17:15:47.996231778 -0400
++++ fcron-2.0.0/conf.c 2004-09-04 17:16:07.589818602 -0400
+@@ -1084,5 +1084,6 @@
+ break ;
+
+ next_file:
++ ;
+ }
+ }