summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-06 20:59:49 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-06 20:59:49 +0000
commit875b77a042e011d49a42b2bd7b3f0482b10c1ad3 (patch)
tree9e202c1d60a8be381891c2192fb209df65a27a70 /sys-apps/file/file-3.41.ebuild
parentadd patch for kernel-2.5 (diff)
downloadgentoo-2-875b77a042e011d49a42b2bd7b3f0482b10c1ad3.tar.gz
gentoo-2-875b77a042e011d49a42b2bd7b3f0482b10c1ad3.tar.bz2
gentoo-2-875b77a042e011d49a42b2bd7b3f0482b10c1ad3.zip
Security update.
Diffstat (limited to 'sys-apps/file/file-3.41.ebuild')
-rw-r--r--sys-apps/file/file-3.41.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/file/file-3.41.ebuild b/sys-apps/file/file-3.41.ebuild
new file mode 100644
index 000000000000..3566ae47555e
--- /dev/null
+++ b/sys-apps/file/file-3.41.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.41.ebuild,v 1.1 2003/03/06 20:59:49 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+SLOT="0"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ if [ "${ARCH}" = "mips" ]; then
+ cd ${S}
+ epatch ${FILESDIR}/${P}-mips-gentoo.diff || die
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/misc \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ -z "`use build`" ] ; then
+ dodoc LEGAL.NOTICE MAINT README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}