summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-04 00:17:11 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-04 00:17:11 +0000
commit3e511ed9cd68471445076969e5a73d4db9cefc44 (patch)
treed30e70a152e905a9b3ef30b5913c70cff7edc015 /sys-apps/file/file-5.00.ebuild
parentFix Manifest. Bug #257538. (diff)
downloadgentoo-2-3e511ed9cd68471445076969e5a73d4db9cefc44.tar.gz
gentoo-2-3e511ed9cd68471445076969e5a73d4db9cefc44.tar.bz2
gentoo-2-3e511ed9cd68471445076969e5a73d4db9cefc44.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/file/file-5.00.ebuild')
-rw-r--r--sys-apps/file/file-5.00.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/file/file-5.00.ebuild b/sys-apps/file/file-5.00.ebuild
new file mode 100644
index 000000000000..566725ef31d8
--- /dev/null
+++ b/sys-apps/file/file-5.00.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.00.ebuild,v 1.1 2009/02/04 00:17:11 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}