summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-02 16:49:59 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-02 16:49:59 +0000
commitaaaf0abf4438ed03273345c97a7b9930d7f767c8 (patch)
treea7e748252c29e8cbdc7fd3b308f36e787cde39f8 /sys-apps/file
parentold (diff)
downloadgentoo-2-aaaf0abf4438ed03273345c97a7b9930d7f767c8.tar.gz
gentoo-2-aaaf0abf4438ed03273345c97a7b9930d7f767c8.tar.bz2
gentoo-2-aaaf0abf4438ed03273345c97a7b9930d7f767c8.zip
Version bump.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-4.20.ebuild59
-rw-r--r--sys-apps/file/files/digest-file-4.203
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 2cc57fae3a40..3af21a8d14e7 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.125 2007/02/13 15:55:29 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.126 2007/03/02 16:49:59 vapier Exp $
+
+*file-4.20 (02 Mar 2007)
+
+ 02 Mar 2007; Mike Frysinger <vapier@gentoo.org> +file-4.20.ebuild:
+ Version bump.
13 Feb 2007; Alexander H. Færøy <eroyf@gentoo.org> file-4.19.ebuild:
Stable on MIPS; bug #165717
diff --git a/sys-apps/file/file-4.20.ebuild b/sys-apps/file/file-4.20.ebuild
new file mode 100644
index 000000000000..0f5b0e4b188c
--- /dev/null
+++ b/sys-apps/file/file-4.20.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.20.ebuild,v 1.1 2007/03/02 16:49:59 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+ epatch "${FILESDIR}"/${PN}-4.19-init-file.patch #163948
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.20 b/sys-apps/file/files/digest-file-4.20
new file mode 100644
index 000000000000..0ea629f25a7a
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.20
@@ -0,0 +1,3 @@
+MD5 709cfeea8b802f80d21da915658cd9fe file-4.20.tar.gz 548412
+RMD160 7fe44509cf9da1df7243ba3787163d50c2fb3193 file-4.20.tar.gz 548412
+SHA256 dd199092f347f1a26c4a8e5f0f7c917f904b2f1e7fc325eb1c875e1470983f1d file-4.20.tar.gz 548412