summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-03 19:43:36 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-03 19:43:36 +0000
commitd9816621831c2933db6b8a7f4b2e14f2386a20fb (patch)
treed28bf2331a2d307d1b9d40e06f9f8dd6b2e5bb56 /sys-apps/file
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-d9816621831c2933db6b8a7f4b2e14f2386a20fb.tar.gz
gentoo-2-d9816621831c2933db6b8a7f4b2e14f2386a20fb.tar.bz2
gentoo-2-d9816621831c2933db6b8a7f4b2e14f2386a20fb.zip
python support #39217
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog5
-rw-r--r--sys-apps/file/file-4.09.ebuild19
2 files changed, 20 insertions, 4 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 93dfe3c7099a..d003af1dac30 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/file
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.42 2004/04/30 18:19:08 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.43 2004/05/03 19:43:36 vapier Exp $
+
+ 03 May 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add python support #39217 by herve coatanhay.
30 Apr 2004; Michael McCabe <randy@gentoo.org> file-4.09.ebuild:
Stable on s390
diff --git a/sys-apps/file/file-4.09.ebuild b/sys-apps/file/file-4.09.ebuild
index f346d824a3b4..1d5d4051b6c1 100644
--- a/sys-apps/file/file-4.09.ebuild
+++ b/sys-apps/file/file-4.09.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.09.ebuild,v 1.2 2004/04/30 18:19:08 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.09.ebuild,v 1.3 2004/05/03 19:43:36 vapier Exp $
inherit flag-o-matic gnuconfig eutils
+use python && inherit distutils
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
HOMEPAGE="ftp://ftp.astron.com/pub/file/"
@@ -12,9 +13,10 @@ SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 s390"
-IUSE=""
+IUSE="python build"
-DEPEND="virtual/glibc"
+DEPEND="virtual/glibc
+ !build? ( python? ( virtual/python ) )"
src_unpack() {
unpack ${A}
@@ -38,6 +40,8 @@ src_compile() {
# Buggy Makefiles. This fixes bug 31356
emake -j1 || die "emake failed"
+
+ use python && cd python && distutils_src_compile
}
src_install() {
@@ -45,7 +49,16 @@ src_install() {
if ! use build ; then
dodoc ChangeLog MAINT README
+ use python && cd python && distutils_src_install
else
rm -rf ${D}/usr/share/man
fi
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}