summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-30 18:00:35 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-30 18:00:35 +0000
commitf77509641b4b895e0dbe2b2c71deca9f187b3b80 (patch)
treeef84ee5a18245d127709f0b9dbae51c17db39aac /sys-apps/fileutils
parent o Added a 'ggi' USE flag to the twin build (diff)
downloadgentoo-2-f77509641b4b895e0dbe2b2c71deca9f187b3b80.tar.gz
gentoo-2-f77509641b4b895e0dbe2b2c71deca9f187b3b80.tar.bz2
gentoo-2-f77509641b4b895e0dbe2b2c71deca9f187b3b80.zip
Added USE build,static,nls again :)
Diffstat (limited to 'sys-apps/fileutils')
-rw-r--r--sys-apps/fileutils/files/digest-fileutils-4.1-r1 (renamed from sys-apps/fileutils/files/digest-fileutils-4.1)0
-rw-r--r--sys-apps/fileutils/fileutils-4.1-r1.ebuild56
-rw-r--r--sys-apps/fileutils/fileutils-4.1.ebuild28
3 files changed, 56 insertions, 28 deletions
diff --git a/sys-apps/fileutils/files/digest-fileutils-4.1 b/sys-apps/fileutils/files/digest-fileutils-4.1-r1
index d32a4e9fe3a1..d32a4e9fe3a1 100644
--- a/sys-apps/fileutils/files/digest-fileutils-4.1
+++ b/sys-apps/fileutils/files/digest-fileutils-4.1-r1
diff --git a/sys-apps/fileutils/fileutils-4.1-r1.ebuild b/sys-apps/fileutils/fileutils-4.1-r1.ebuild
new file mode 100644
index 000000000000..c71c7568f1a1
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1-r1.ebuild,v 1.1 2001/04/30 18:00:35 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --bindir=/bin ${myconf}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info bindir=${D}/bin install
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+ cd ${S}
+ dodoc COPYING NEWS README* THANKS TODO ChangeLog ChangeLog-1997 AUTHORS
+ else
+ cd ${S}/src
+ into /
+ dobin chgrp chown dd dir du ln mkdir mknod rm touch \
+ chmod cp df ls mkfifo mv rmdir sync
+ newbin ginstall install
+ dosym /bin/install /usr/bin/install
+ fi
+
+}
+
diff --git a/sys-apps/fileutils/fileutils-4.1.ebuild b/sys-apps/fileutils/fileutils-4.1.ebuild
deleted file mode 100644
index 19402b036471..000000000000
--- a/sys-apps/fileutils/fileutils-4.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.ebuild,v 1.1 2001/04/29 19:16:42 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
-SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
-HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
-
-DEPEND=">=sys-libs/glibc-2.1.3"
-
-src_compile() {
- #we are waiting for GNU fileutils 4.0.30 which will become standard in Gentoo 1.0
- #until then, we wait.
- try ./configure --prefix=/usr
- try make ${MAKEOPTS}
-}
-
-src_install() {
- dodoc COPYING NEWS README* THANKS TODO ChangeLog ChangeLog-1997 AUTHORS
- make prefix=${D}/usr mandir=${D}/usr/share/man install
- cd ${D}
- mv usr/bin .
- rm -rf usr/lib
-}
-