summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-28 07:15:31 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-28 07:15:31 +0000
commitd1126e67ac4d11c75bd5aeb5bb256b6e73dd5dc2 (patch)
treeb82997fb3b907b9ed041b97f54082003bc8e807a /sys-apps/gawk/files
parentBump to 0.8.0, closing bug #113923, thanks to all contributors on this bug (diff)
downloadgentoo-2-d1126e67ac4d11c75bd5aeb5bb256b6e73dd5dc2.tar.gz
gentoo-2-d1126e67ac4d11c75bd5aeb5bb256b6e73dd5dc2.tar.bz2
gentoo-2-d1126e67ac4d11c75bd5aeb5bb256b6e73dd5dc2.zip
fix by Diego Pettenò to respect CFLAGS/LDFLAGS #127820
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'sys-apps/gawk/files')
-rw-r--r--sys-apps/gawk/files/filefuncs/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/gawk/files/filefuncs/Makefile b/sys-apps/gawk/files/filefuncs/Makefile
index bd2cfca7ee94..2f1a05f5d2c2 100644
--- a/sys-apps/gawk/files/filefuncs/Makefile
+++ b/sys-apps/gawk/files/filefuncs/Makefile
@@ -1,7 +1,7 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.7 2005/09/03 20:31:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.8 2006/03/28 07:15:31 vapier Exp $
CC ?= gcc
LD = $(CC)
@@ -35,10 +35,10 @@ ifeq ($(DOIT),yes)
all: $(TARGET_LIB)
$(TARGET).o: $(TARGET).c
- $(CC) -shared -Wall -DHAVE_CONFIG_H -c -O2 -fPIC -I$(AWKINCDIR) $^
+ $(CC) $(CLAGS) -shared -Wall -DHAVE_CONFIG_H -c -O2 -fPIC -I$(AWKINCDIR) $^
$(TARGET_LIB): $(TARGET).o
- $(LD) -o $@ -shared -Wl,-soname -Wl,$(TARGET).so.$(MAJORVER) $^
+ $(LD) $(LDFLAGS) -o $@ -shared -Wl,-soname -Wl,$(TARGET).so.$(MAJORVER) $^
install: $(TARGET_LIB)
install -m 0755 -d $(DESTDIR)/$(LIBDIR)/rcscripts