summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-05 05:54:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-05 05:54:00 +0000
commit8893af90d649badc68e1fd19172b7b56ec501cb8 (patch)
tree1142f6700d4d2aac9d10c4a736e77120466f7ad3 /sys-apps/gawk
parentRekeyword for mips. Not sure why it was dropped in the first place. (diff)
downloadgentoo-2-8893af90d649badc68e1fd19172b7b56ec501cb8.tar.gz
gentoo-2-8893af90d649badc68e1fd19172b7b56ec501cb8.tar.bz2
gentoo-2-8893af90d649badc68e1fd19172b7b56ec501cb8.zip
Update mktime test #220040.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog6
-rw-r--r--sys-apps/gawk/files/autoconf-mktime-2.61.patch47
-rw-r--r--sys-apps/gawk/gawk-3.1.6.ebuild3
3 files changed, 54 insertions, 2 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 09be67287d50..7ed6674f9e6c 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.116 2008/05/05 04:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.117 2008/05/05 05:54:00 vapier Exp $
+
+ 05 May 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/autoconf-mktime-2.61.patch, gawk-3.1.6.ebuild:
+ Update mktime test #220040.
*gawk-3.1.6 (05 May 2008)
diff --git a/sys-apps/gawk/files/autoconf-mktime-2.61.patch b/sys-apps/gawk/files/autoconf-mktime-2.61.patch
new file mode 100644
index 000000000000..345169f9a5b5
--- /dev/null
+++ b/sys-apps/gawk/files/autoconf-mktime-2.61.patch
@@ -0,0 +1,47 @@
+--- configure
++++ configure
+@@ -10518,6 +10791,7 @@
+ # endif
+ #endif
+
++#include <limits.h>
+ #include <stdlib.h>
+
+ #ifdef HAVE_UNISTD_H
+@@ -10666,12 +10940,15 @@
+ isn't worth using anyway. */
+ alarm (60);
+
+- for (time_t_max = 1; 0 < time_t_max; time_t_max *= 2)
+- continue;
+- time_t_max--;
+- if ((time_t) -1 < 0)
+- for (time_t_min = -1; (time_t) (time_t_min * 2) < 0; time_t_min *= 2)
+- continue;
++ for (;;)
++ {
++ t = (time_t_max << 1) + 1;
++ if (t <= time_t_max)
++ break;
++ time_t_max = t;
++ }
++ time_t_min = - ((time_t) ~ (time_t) 0 == (time_t) -1) - time_t_max;
++
+ delta = time_t_max / 997; /* a suitable prime number */
+ for (i = 0; i < N_STRINGS; i++)
+ {
+@@ -10686,10 +10963,12 @@
+ && mktime_test ((time_t) (60 * 60 * 24))))
+ return 1;
+
+- for (j = 1; 0 < j; j *= 2)
++ for (j = 1; ; j <<= 1)
+ if (! bigtime_test (j))
+ return 1;
+- if (! bigtime_test (j - 1))
++ else if (INT_MAX / 2 < j)
++ break;
++ if (! bigtime_test (INT_MAX))
+ return 1;
+ }
+ return ! (irix_6_4_bug () && spring_forward_gap () && year_2050_test ());
diff --git a/sys-apps/gawk/gawk-3.1.6.ebuild b/sys-apps/gawk/gawk-3.1.6.ebuild
index cb49ee08ecb9..ec576e6dcbbd 100644
--- a/sys-apps/gawk/gawk-3.1.6.ebuild
+++ b/sys-apps/gawk/gawk-3.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.6.ebuild,v 1.1 2008/05/05 04:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.6.ebuild,v 1.2 2008/05/05 05:54:00 vapier Exp $
inherit eutils toolchain-funcs multilib
@@ -26,6 +26,7 @@ src_unpack() {
cp -r "${FILESDIR}"/filefuncs "${SFFS}" || die "cp failed"
cd "${S}"
+ epatch "${FILESDIR}"/autoconf-mktime-2.61.patch #220040
epatch "${FILESDIR}"/${PN}-3.1.3-getpgrp_void.patch
}