summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-13 22:13:19 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-13 22:13:19 +0000
commitbb325802e7a8fad7a373d935c1c9f4fb71ea6424 (patch)
tree8411a414b4f064bcf0959f6f669021185fe2ed6a /sys-apps/gawk
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-bb325802e7a8fad7a373d935c1c9f4fb71ea6424.tar.gz
gentoo-2-bb325802e7a8fad7a373d935c1c9f4fb71ea6424.tar.bz2
gentoo-2-bb325802e7a8fad7a373d935c1c9f4fb71ea6424.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog7
-rw-r--r--sys-apps/gawk/gawk-4.1.0.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index e60840bd5ad0..b236ca6525e4 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.160 2013/02/19 03:07:42 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.161 2013/05/13 22:13:19 vapier Exp $
+
+*gawk-4.1.0 (13 May 2013)
+
+ 13 May 2013; Mike Frysinger <vapier@gentoo.org> +gawk-4.1.0.ebuild:
+ Version bump.
19 Feb 2013; Zac Medico <zmedico@gentoo.org> gawk-4.0.2.ebuild:
Add ~arm-linux keyword.
diff --git a/sys-apps/gawk/gawk-4.1.0.ebuild b/sys-apps/gawk/gawk-4.1.0.ebuild
new file mode 100644
index 000000000000..a18471042b0f
--- /dev/null
+++ b/sys-apps/gawk/gawk-4.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-4.1.0.ebuild,v 1.1 2013/05/13 22:13:19 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls readline"
+
+# older gawk's provided shared lib for baselayout-1
+RDEPEND="!<sys-apps/baselayout-2.0.1
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in #413327
+}
+
+src_configure() {
+ export ac_cv_libsigsegv=no
+ econf \
+ --libexec='$(libdir)/misc' \
+ $(use_enable nls) \
+ $(use_with readline)
+}
+
+src_install() {
+ rm -rf README_d # automatic dodocs barfs
+ default
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h || die
+ rm "${ED}"/usr/include/awk/config.h || die
+}
+
+pkg_postinst() {
+ # symlink creation here as the links do not belong to gawk, but to any awk
+ if has_version app-admin/eselect && has_version app-admin/eselect-awk ; then
+ eselect awk update ifunset
+ else
+ local l
+ for l in "${EROOT}"usr/share/man/man1/gawk.1* "${EROOT}"usr/bin/gawk; do
+ [[ -e ${l} && ! -e ${l/gawk/awk} ]] && ln -s "${l##*/}" "${l/gawk/awk}"
+ done
+ [[ ! -e ${EROOT}bin/awk ]] && ln -s "../usr/bin/gawk" "${EROOT}bin/awk"
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-admin/eselect-awk ; then
+ eselect awk update ifunset
+ fi
+}