summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2015-03-18 21:42:34 +0000
committerPaul Varner <fuzzyray@gentoo.org>2015-03-18 21:42:34 +0000
commitc6ddd20f1f13a4f4ca42f2b5a7f72433628b5b78 (patch)
treeb8c6c3fd71e3da3e9ffbd8b0d3bb734396d399ec /sys-apps/gentoo-functions
parentx86 stable, see bug 543620. (diff)
downloadgentoo-2-c6ddd20f1f13a4f4ca42f2b5a7f72433628b5b78.tar.gz
gentoo-2-c6ddd20f1f13a4f4ca42f2b5a7f72433628b5b78.tar.bz2
gentoo-2-c6ddd20f1f13a4f4ca42f2b5a7f72433628b5b78.zip
Fix ebuilds to install files to prefix filesystem. (Bug 543710)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x6E1CBA7B)
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/ChangeLog6
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild6
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild8
3 files changed, 16 insertions, 4 deletions
diff --git a/sys-apps/gentoo-functions/ChangeLog b/sys-apps/gentoo-functions/ChangeLog
index 1dfb5a2c2099..fe58d4dc56df 100644
--- a/sys-apps/gentoo-functions/ChangeLog
+++ b/sys-apps/gentoo-functions/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/gentoo-functions
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/ChangeLog,v 1.28 2015/03/17 18:14:57 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/ChangeLog,v 1.29 2015/03/18 21:42:34 fuzzyray Exp $
+
+ 18 Mar 2015; Paul Varner <fuzzyray@gentoo.org> gentoo-functions-0.9.ebuild,
+ gentoo-functions-9999.ebuild:
+ Fix ebuilds to install files to prefix filesystem. (Bug 543710)
*gentoo-functions-0.9 (17 Mar 2015)
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild
index 51d3079b8783..465a9d6e6746 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild,v 1.1 2015/03/17 18:14:57 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.9.ebuild,v 1.2 2015/03/18 21:42:34 fuzzyray Exp $
EAPI=5
@@ -24,3 +24,7 @@ IUSE=""
src_prepare() {
tc-export CC
}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index f75276851bb4..c8ae8ba4ec5f 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v 1.4 2014/07/06 21:24:10 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v 1.5 2015/03/18 21:42:34 fuzzyray Exp $
EAPI=5
@@ -24,3 +24,7 @@ IUSE=""
src_prepare() {
tc-export CC
}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}