summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-23 14:13:26 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-23 14:13:26 +0000
commit5549abd0582dd7f6c8a9c1ea4496db8e5e81cac3 (patch)
tree73b7dd328101199e934289e9c83f331f02bc230b /sys-apps/getent
parentcleanup old, add sub-slot dep on protobuf (diff)
downloadgentoo-2-5549abd0582dd7f6c8a9c1ea4496db8e5e81cac3.tar.gz
gentoo-2-5549abd0582dd7f6c8a9c1ea4496db8e5e81cac3.tar.bz2
gentoo-2-5549abd0582dd7f6c8a9c1ea4496db8e5e81cac3.zip
Initial commit: script to emulated glibc's getent utility
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/getent')
-rw-r--r--sys-apps/getent/ChangeLog4
-rw-r--r--sys-apps/getent/getent-0.ebuild35
-rw-r--r--sys-apps/getent/getent-9999.ebuild35
-rw-r--r--sys-apps/getent/metadata.xml9
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/getent/ChangeLog b/sys-apps/getent/ChangeLog
new file mode 100644
index 000000000000..43fedb851a46
--- /dev/null
+++ b/sys-apps/getent/ChangeLog
@@ -0,0 +1,4 @@
+# ChangeLog for sys-apps/getent
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/getent/ChangeLog,v 1.1 2014/01/23 14:13:26 blueness Exp $
+
diff --git a/sys-apps/getent/getent-0.ebuild b/sys-apps/getent/getent-0.ebuild
new file mode 100644
index 000000000000..da16699365db
--- /dev/null
+++ b/sys-apps/getent/getent-0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/getent/getent-0.ebuild,v 1.1 2014/01/23 14:13:26 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="Script to emulate the behavior of glibc's getent utility"
+HOMEPAGE="http://www.uclibc.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI="http://git.uclibc.org/uClibc/plain/extra/scripts/${PN}"
+ KEYWORDS=""
+ MY_P=${PN}
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}"
+ KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+ MY_P=${P}
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc
+"
+
+src_unpack() {
+ mkdir ${P}
+ cp "${DISTDIR}"/${MY_P} ${P}/${PN}
+}
+
+src_install() {
+ dobin getent
+}
diff --git a/sys-apps/getent/getent-9999.ebuild b/sys-apps/getent/getent-9999.ebuild
new file mode 100644
index 000000000000..0690e469369a
--- /dev/null
+++ b/sys-apps/getent/getent-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/getent/getent-9999.ebuild,v 1.1 2014/01/23 14:13:26 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="Script to emulate the behavior of glibc's getent utility"
+HOMEPAGE="http://www.uclibc.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI="http://git.uclibc.org/uClibc/plain/extra/scripts/${PN}"
+ KEYWORDS=""
+ MY_P=${PN}
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}"
+ KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+ MY_P=${P}
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc
+"
+
+src_unpack() {
+ mkdir ${P}
+ cp "${DISTDIR}"/${MY_P} ${P}/${PN}
+}
+
+src_install() {
+ dobin getent
+}
diff --git a/sys-apps/getent/metadata.xml b/sys-apps/getent/metadata.xml
new file mode 100644
index 000000000000..b3560e83a683
--- /dev/null
+++ b/sys-apps/getent/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>