summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-01 18:04:28 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-01 18:04:28 +0000
commit02d8528c680a5227e0586066eabab1260e2fe4bd (patch)
tree4c7bc4f2b075059d595f6b0e33b3616db6f593a0 /sys-apps/gli
parentAdd ~ia64 (diff)
downloadgentoo-2-02d8528c680a5227e0586066eabab1260e2fe4bd.tar.gz
gentoo-2-02d8528c680a5227e0586066eabab1260e2fe4bd.tar.bz2
gentoo-2-02d8528c680a5227e0586066eabab1260e2fe4bd.zip
Added 0.6.2, which was going to be used for 2007.1, but will now be used for 2008.0 and made sure 0.5.4 wasn't stable on any arches.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/gli')
-rw-r--r--sys-apps/gli/ChangeLog11
-rw-r--r--sys-apps/gli/gli-0.5.4.ebuild6
-rw-r--r--sys-apps/gli/gli-0.6.2.ebuild70
3 files changed, 82 insertions, 5 deletions
diff --git a/sys-apps/gli/ChangeLog b/sys-apps/gli/ChangeLog
index 58c58ca41db1..791aaf580c12 100644
--- a/sys-apps/gli/ChangeLog
+++ b/sys-apps/gli/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/gli
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/ChangeLog,v 1.10 2007/05/07 18:52:27 wolf31o2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/ChangeLog,v 1.11 2008/02/01 18:04:28 wolf31o2 Exp $
+
+*gli-0.6.2 (01 Feb 2008)
+
+ 01 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org> gli-0.5.4.ebuild,
+ +gli-0.6.2.ebuild:
+ Added 0.6.2, which was going to be used for 2007.1, but will now be used for
+ 2008.0 and made sure 0.5.4 wasn't stable on any arches.
*gli-0.5.4 (07 May 2007)
diff --git a/sys-apps/gli/gli-0.5.4.ebuild b/sys-apps/gli/gli-0.5.4.ebuild
index 0c650db87afc..cb53209db51c 100644
--- a/sys-apps/gli/gli-0.5.4.ebuild
+++ b/sys-apps/gli/gli-0.5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.5.4.ebuild,v 1.1 2007/05/07 18:52:27 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.5.4.ebuild,v 1.2 2008/02/01 18:04:28 wolf31o2 Exp $
inherit python eutils
@@ -11,7 +11,7 @@ SRC_URI="http://dev.gentoo.org/~agaffney/${PN}/releases/installer-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
IUSE="gtk"
RDEPEND=">=dev-python/pyparted-1.7.0
diff --git a/sys-apps/gli/gli-0.6.2.ebuild b/sys-apps/gli/gli-0.6.2.ebuild
new file mode 100644
index 000000000000..3b4541bc4413
--- /dev/null
+++ b/sys-apps/gli/gli-0.6.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.6.2.ebuild,v 1.1 2008/02/01 18:04:28 wolf31o2 Exp $
+
+inherit python eutils
+
+DESCRIPTION="Gentoo Linux Installer"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/installer/"
+#SRC_URI="http://dev.gentoo.org/~agaffney/gli/snapshots/installer-${PV}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~agaffney/${PN}/releases/installer-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-python/pyparted-1.7.0
+ gtk? ( >=dev-python/pygtk-2.4.0 )
+ =dev-python/pythondialog-2.7*
+ sys-fs/e2fsprogs
+ sys-fs/reiserfsprogs
+ sys-fs/dosfstools
+ sys-fs/xfsprogs
+ amd64? ( sys-fs/ntfsprogs )
+ ppc? (
+ sys-fs/ntfsprogs
+ sys-fs/hfsutils
+ sys-fs/hfsplusutils )
+ x86? (
+ sys-fs/ntfsprogs
+ sys-fs/hfsutils
+ sys-fs/hfsplusutils )"
+
+S=${WORKDIR}/installer-${PV}
+
+dir=/opt/installer
+Ddir=${D}/${dir}
+
+src_install() {
+ dodir ${dir}
+ exeinto ${dir}/bin
+ use !gtk && rm -rf ${S}/src/fe/gtk
+ # We need to make sure we get our scripts
+ doexe ${S}/bin/installer ${S}/bin/installer-dialog || \
+ die "copying installer scripts"
+ cp -a ${S}/src/* ${Ddir}
+ chown -R root:0 ${Ddir}
+ dodir /usr/bin
+ if use gtk; then
+ doexe ${S}/bin/installer-gtk || die "copying gtk script"
+ make_wrapper installer-gtk ./installer-gtk ${dir}/bin
+ fi
+ make_wrapper installer-dialog ./installer-dialog ${dir}/bin
+ make_wrapper installer ./installer ${dir}/bin
+ doicon ${FILESDIR}/gli.png ${FILESDIR}/gli-dialog.png
+ domenu ${FILESDIR}/installer-gtk.desktop \
+ ${FILESDIR}/installer-dialog.desktop \
+ ${FILESDIR}/installer-faq.desktop
+}
+
+pkg_postinst() {
+ python_mod_optimize ${dir}
+ einfo "The Gentoo Linux Installer is currently only usable for two situations."
+ einfo "The first is for building an install profile."
+ einfo "The second is for installing using official Gentoo release media."
+ echo
+ ewarn "If you are trying to use the installer for anything else, please"
+ ewarn "file patches with any bugs."
+ echo
+}